Opened 10 years ago

Closed 10 years ago

#4999 closed bug (duplicate)

Default desktop background image isn't horizontally centered

Reported by: idefix Owned by: anevilyak
Priority: low Milestone: R1
Component: Kits/libtracker.so Version: R1/Development
Keywords: Cc:
Blocked By: #2882 Blocking:
Has a Patch: no Platform: All

Description

Since hrev22040, Haiku has a default background image set for the desktop.

Line 499 of TrackerInitialState.cpp sets the x-position of that image:

logoPos.x = floorf((screen.Frame().Width() - 605) * (sqrtf(5) - 1) / 2);

I don't understand the * (sqrtf(5) - 1) part of that line, as it shifts the image slightly to the left, causing it to not be horizontally centered.

The background image should be horizontally centered if that line changes to:

logoPos.x = floorf((screen.Frame().Width() - 605) / 2);

Change History (1)

comment:1 by axeld, 10 years ago

Blocked By: 2882 added
Resolution: duplicate
Status: newclosed

Duplicate of #2882. In nutshell, the logo is placed at the golden ratio.

Note: See TracTickets for help on using tickets.