Opened 10 years ago

Closed 9 years ago

#5096 closed bug (fixed)

intel_extreme regression: 1024x600 resolution not detected after [33633]

Reported by: JeremyVisser Owned by: axeld
Priority: normal Milestone: R1
Component: Drivers/Graphics/intel_extreme Version: R1/Development
Keywords: Cc: haiku-trac@…
Blocked By: Blocking:
Has a Patch: no Platform: All

Description

On revision 33632, when I boot Haiku on my ASUS Eee 901 (with an Intel GMA 945), the laptop's native 1024x600 resolution is detected and applied out-of-the-box.

On revision [33633], the resolution 1024x600 is not available for use, and 1024x768 is used instead, which is incorrect, and the bottom of the screen is cut off.

Change History (15)

comment:1 by ahwayakchih, 10 years ago

I can confirm that on hrev35327. Same EeePC model, same chipset, and resolution is also wrongly set to 1024x768 (with no other option to select from on Screen preferences). I have downloaded nightly from hrev33610, copied accelerant and driver and resolution was set correctly :).

comment:2 by JeremyVisser, 10 years ago

Just FYI, I'm running hrev36131, and 1024x600 was again correctly detected on my machine.

ahwayakchih, can you confirm this too?

comment:3 by ahwayakchih, 10 years ago

JeremyVisser, i tried hrev36218 (GCC2 Hybrid build) and it still sets resolution to 1024x768 :(.

comment:4 by JeremyVisser, 10 years ago

I was running the GCC4 hybrid build myself. Also, I ran the installer from within a VirtualBox VM and used that to install to my main drive, then I physically rebooted into the new install, and 1024x600 was there.

Puzzling. Would be good if we could get some feedback from Haiku devs on this.

comment:5 by ahwayakchih, 10 years ago

Could it be that installer changes some settings? I was sure it just copies stuff to disk (the beauty of it/BeOS was simplicity after all :), but maybe something changed in meantime. I simply downloaded nightly build image, loaded it onto USB and booted EeePC from it. Maybe difference is in USB vs HD?

comment:6 by stippi, 10 years ago

Well... the Installer just copies everything, indeed. But with the semi-writabe CD-images, it will also copy the "virtual" settings which would otherwise be lost if you were to reboot the CD. This is used for example for the language. If you boot from a CD, pick a language, the setting will be stored in the "write overlay". When you install from this life-image, the setting will be written for real on the hard-disk, which makes the system reboot into the correct language, without any Installer trickery. That's of course just one example. Any other customizations you do while booted into the live-CD would be copied by the Installer.

comment:7 by ahwayakchih, 10 years ago

Thanks for the information stippi :). Does that mean, that driver/screen settings where copied too? Wouldn't it change to default after booting on different hardware (current driver works like it didn't see any other resolution available, because Screen settings show only 1024x768) and not seeing 1024x600 available anymore?

JeremyVisser, if You open Screen settings (on a "working ok" installation You mentioned :), does it show correct resolution to select, or does it show only 1024x768?

in reply to:  7 comment:8 by JeremyVisser, 10 years ago

Replying to ahwayakchih:

JeremyVisser, if You open Screen settings (on a "working ok" installation You mentioned :), does it show correct resolution to select, or does it show only 1024x768?

If I open the Screen settings page, it shows 1024x600 like normal. (1024x600 is the only option.) When it was broken, 800x600, 1024x768 (and 640x480, I think) were shown as options instead.

comment:9 by ahwayakchih, 10 years ago

Strange, i never got any other resolution than 1024x768 to select on Screen settings.

Can it be that the same GFX chipset gives different results? Maybe it's not the same after all (though i know intel driver is used because of test mentioned in my first comment here :)...

Ubuntu's "lshw" command returns something like this:

        *-display:0 UNCLAIMED
             description: VGA compatible controller
             product: Mobile 945GME Express Integrated Graphics Controller
             vendor: Intel Corporation
             physical id: 2
             bus info: pci@0000:00:02.0
             version: 03
             width: 32 bits
             clock: 33MHz
             capabilities: msi pm bus_master cap_list
             configuration: latency=0
        *-display:1 UNCLAIMED
             description: Display controller
             product: Mobile 945GM/GMS/GME, 943/940GML Express Integrated Graphics Controller
             vendor: Intel Corporation
             physical id: 2.1
             bus info: pci@0000:00:02.1
             version: 03
             width: 32 bits
             clock: 33MHz
             capabilities: pm bus_master cap_list
             configuration: latency=0

comment:10 by stippi, 10 years ago

Yes, the same (unsupported) chipset can give different results, since the results depend on the VESA BIOS only. It can be implemented differently by different *board* vendors, not necessarily the chipset vendor.

For example, I am a happy owner of a GTX-285 board where the vendor (Club3D in my case) has included a VESA BIOS implementation that will check the EDID of the monitor, and modify the last entry in the VESA BIOS mode list to reflect the preferred mode of the connected monitor, as 8 bit and 32 bit mode even. This way I always get the perfect resolution with the VESA driver.

In any case, this ticket is about a regression in the intel_extreme driver, which has nothing to do with GFX nor the VESA BIOS. :-)

comment:11 by sexybiggetje, 9 years ago

Cc: haiku-trac@… added

comment:12 by pulkomandy, 9 years ago

I have the same problem on my new thinkpad T60. Screen is 1400x1050, only available resolution is 1280x1024, leaving me with black borders around the screen. My pixels feel bored. If you need remote access to my machine for tests, please let me know.

comment:13 by pulkomandy, 9 years ago

This should be fixed in hrev38329. Can you check if it works for you ?

in reply to:  13 comment:14 by JeremyVisser, 9 years ago

Replying to pulkomandy:

This should be fixed in hrev38329. Can you check if it works for you ?

Yep, just booted hrev38837 on my Eee 901 and 1024x600 was used out-of-the-box for me. Awesome! Looks like it’s fixed. :-)

comment:15 by pulkomandy, 9 years ago

Resolution: fixed
Status: newclosed
Note: See TracTickets for help on using tickets.