Opened 13 years ago

Closed 13 years ago

Last modified 13 years ago

#516 closed bug (fixed)

Bad font hinting

Reported by: diver Owned by: jackburton
Priority: normal Milestone: R1
Component: - General Version:
Keywords: Cc:
Blocked By: Blocking:
Has a Patch: no Platform: All

Description

Open Fonts and set font size to use 11pt leaving font unchanged. Restart tracker and open Find window. Now type 10-20 symbols, you should see font hinting is getting worse each time you press a key!

Note, i restarted tracker using vulcan death grip and desktop didn't get cleared for some reason. Tested under vmware and on real hardware with rev17159.

Change History (17)

comment:1 by axeld, 13 years ago

Owner: changed from axeld to stippi

comment:2 by jackburton, 13 years ago

Owner: changed from stippi to jackburton

comment:3 by jackburton, 13 years ago

What's happening is that the text is redrawn over and over without being erased first. I'll look into it, as it's my fault.

comment:4 by jackburton, 13 years ago

Status: newassigned

comment:5 by jackburton, 13 years ago

I've fixed this in my local tree. I'll commit it in the next few days.

comment:6 by jackburton, 13 years ago

Status: assignedclosed

comment:7 by jackburton, 13 years ago

Fixed in hrev17342

comment:8 by jackburton, 13 years ago

Resolution: fixed

comment:9 by diver, 13 years ago

I thinks there is something left. If you check Expand new applications option in deskbar and open several windows you could see font corruption in team menu items. Could you have a look, or maybe i should open another bug for this?

comment:10 by diver, 13 years ago

Cc: axeld@… added

comment:11 by diver, 13 years ago

Status: closedreopened

comment:12 by diver, 13 years ago

Resolution: fixed

comment:13 by diver, 13 years ago

Reopening as Comment #4 is not fixed yet...

comment:14 by jackburton, 13 years ago

Maybe you should open another bug, it's not related at all to the original problem. By the way I cannot even reproduce the new problem.

comment:15 by diver, 13 years ago

(In reply to comment #6)

Maybe you should open another bug, it's not related at all to the original

problem.

By the way I cannot even reproduce the new problem.

Ok, closing bug. New #680 created.

comment:16 by diver, 13 years ago

Resolution: fixed

comment:17 by diver, 13 years ago

Status: reopenedclosed
Note: See TracTickets for help on using tickets.