Opened 14 years ago

Closed 12 years ago

#517 closed bug (fixed)

Copying a large file drops to KDL

Reported by: diver Owned by: axeld
Priority: blocker Milestone: R1/alpha1
Component: System/Kernel Version:
Keywords: Cc:
Blocked By: Blocking:
Has a Patch: no Platform: All

Description (last modified by axeld)

While trying to copt video file (350Mb) from R5 partition to haiku it brings me to kdl. After reboot i retry to do the same with the same result. Tested on real hardware with rev17159.

Attachments (1)

vm_allocate.PNG (37.7 KB ) - added by rdaneel 13 years ago.
Its happening in rev 20288 too.

Download all attachments as: .zip

Change History (8)

comment:1 by axeld, 14 years ago

Summary: PANIC: vm_allocate_page: out of memory! page state = 4Copying a large file drops to KDL

comment:2 by axeld, 14 years ago

Drops to KDL with: PANIC: vm_allocate_page: out of memory! page state = 4

comment:3 by axeld, 13 years ago

Description: modified (diff)
Platform: All
Priority: criticalblocker

by rdaneel, 13 years ago

Attachment: vm_allocate.PNG added

Its happening in rev 20288 too.

comment:4 by scottmc, 12 years ago

With hrev22317 I no longer get KDL but tracker freezes in the middle of the copy. I made 8 copies of the haiku.image file which is 100meg, and then tried to copy all 8 to a new folder on the same partition. It copies the first 5 files ok and then gets to 61 meg on the 6th file before freezing up. Pressing F12 will let me get to KDL. If I only copy 5 files and then try copying 2 or 3 more I also get this freeze. I see that there's been more work on the vm since hrev22317 so I'm assuming this is activly being worked on. I'll check it again in a few more days. Seems like progress is being made, but as of hrev22317 not working correctly yet.

comment:5 by axeld, 12 years ago

Milestone: R1R1/alpha

comment:6 by scottmc, 12 years ago

With hrev22813 I was able to copy a 100meg haiku image file several times, creating 20 copies of it. The when trying to copy those 20 copies to a new folder it got about half-way (around 1Gb) before droping into kdl with a "page requested but there is none" error. After creating the 10th copy I started getting the missing icon bug. So the error is different than before but still not fixed.

comment:7 by axeld, 12 years ago

Resolution: fixed
Status: newclosed

Fixed since some time. It doesn't crash anymore, and it doesn't deadlock. There may still be other problems, but the most important things are done.

Note: See TracTickets for help on using tickets.