Opened 10 years ago

Closed 10 years ago

#5225 closed bug (invalid)

[PackageInstaller] fails to complete installation of cabextract.12.pkg

Reported by: diver Owned by: sil2100
Priority: normal Milestone: R1
Component: Applications/PackageInstaller Version: R1/alpha1
Keywords: Cc:
Blocked By: Blocking:
Has a Patch: no Platform: All

Description

cabextract.12.pkg is attached.
Tested with hrev34970 under VirtualBox

Attachments (2)

cabextract.12.pkg (320.0 KB) - added by diver 10 years ago.
PackageInstaller.png (161.8 KB) - added by diver 10 years ago.

Download all attachments as: .zip

Change History (7)

Changed 10 years ago by diver

Attachment: cabextract.12.pkg added

comment:1 Changed 10 years ago by sil2100

Status: newin-progress

I cannot seem to reproduce this problem on hrev34983 (running on qemu). Does this still not work on your end? Does it show some error message that the installation fails? I would be grateful for more details.

Changed 10 years ago by diver

Attachment: PackageInstaller.png added

comment:2 Changed 10 years ago by diver

Still here in hrev34983, screenshot attached, look at the alert.

comment:3 Changed 10 years ago by sil2100

Try changing the install directory (the "Install to:" drop down box). Since I see on the screenshot that right now it's set to 'none'. Setting to Haiku (on qemu) or any other valid location should make it install normally.

Tell me if this was the issue.

If it was, then nevertheless it's still a bug that needs to be fixed. The default install directory should be set to some valid location, so that users won't get more problems like this. But this is a thing for a new ticket.

comment:4 Changed 10 years ago by diver

Changing the install directory to "Haiku" allows this package to be installed normally.

comment:5 Changed 10 years ago by sil2100

Resolution: invalid
Status: in-progressclosed

Closing this ticket, since this issue is fixed. We have #5231 for the overall problem.

Note: See TracTickets for help on using tickets.