Opened 10 years ago

Closed 9 years ago

#5539 closed bug (duplicate)

Can't boot from LiveCD

Reported by: xsive Owned by: axeld
Priority: normal Milestone: R1/alpha3
Component: System/Boot Loader Version: R1/alpha1
Keywords: sbx00 Cc: umccullough
Blocked By: Blocking:
Has a Patch: no Platform: x86

Description

I'm unable to boot from the Haiku R1 Live CD on my desktop PC. Also I'm unable to select the safe mode as I cannot get into the menu as F12 doesn't work, all I have is a blinking white cursor top left and nothing else so I can't see how to debug?

My system is

AMD Athlon XP 64 4200+ Nvidia 9800 GTX+ IDE HD 2GB RAM

Anything else I could post to help with this issue?

Change History (23)

comment:1 by ccipri, 10 years ago

on the last nightly builds you have to hold "shift" pressed to enter the safte mode. (On the alpha1 cd I think you can enter safe mode by pressing space-bar).

comment:2 by xsive, 10 years ago

sorry don't know why I had F12 in my head, meant space bar and won't go into menu, just flashing cursor then it moves along to the right a bit and continues flashing

comment:3 by xsive, 10 years ago

tried with latest nightly build still same problem, flashing cursor on left, then lots of ........... followed by another flashing cursor which seems to be brighter than the first?

comment:4 by xsive, 10 years ago

More info on my chipset :

IDE port by AMD® SB600 Audio

  • Chipset integrated by Realtek® ALC888

Supports 10/100 Fast Ethernet by Realtek 8101E

Chipset

  • AMD® 690G and SB600 Chipset

comment:5 by mmadia, 10 years ago

Priority: highnormal

Please do not raise the priority of tickets; it's preferred to be done by the devs. Is this with R1 Alpha 1 or a nightly image?

comment:6 by xsive, 10 years ago

ok sorry didn't know about the priority levels. It does it with both the R1 alpha image and the nightly builds

comment:7 by xsive, 10 years ago

Component: - GeneralSystem/Boot Loader
Owner: changed from nobody to axeld
Platform: x86x86-64

comment:8 by bonefish, 10 years ago

Platform: x86-64x86

There is no x86-64 Haiku yet.

comment:9 by bonefish, 10 years ago

Milestone: R1R1/alpha2

comment:10 by starsseed, 10 years ago

Blocked By: 4408 added

comment:11 by fatigatti, 9 years ago

I have the exact same problem (blinking cursor, nothing happens) on my machine. Here's the specs, maybe they could be useful to identify if there's something common to all the machines in which the bootloader hangs.

AMD Sempron LE-1150 (2.00 GHz) Motherboard: MSI K9AGM3 (North Bridge: AMD 690G, South Bridge: SB600) 1GB RAM Network cards: Realtek 8111B Gigabit (Integrated), Realtek 8185 Wireless G HDD WD 160 GB

I tried with ISO and anyboot images, of both Alpha 2 and the latest nightly build to date. Always the same: blinking cursor, the bootloader hangs. However, all the images work OK using Virtualbox on Windows 7, on the same computer (because VirtualBox emulates hardware than doesn't give trouble to Haiku).

comment:12 by starsseed, 9 years ago

Sonic reports a quite similar issue in the forum ! See : problem haiku cd booting old pc

comment:13 by Xbertl, 9 years ago

I have the same problem, but I already give up hope that this problem can be fixed. I reported this bug 19 month ago: http://dev.haiku-os.org/ticket/3441

comment:14 by mmadia, 9 years ago

Keywords: sbx00 added; boot cd removed

Possibly related to the SBx00 chipset issues?

comment:15 by xsive, 9 years ago

Possibly but who knows noone can seem to get a syslog for this problem

comment:16 by Xbertl, 9 years ago

But I have the same problem on a fujitsu-siemens server mainboard with the Intel 440BX Chipset.
So I don't think that this is only a problem of my AMD SB600 and other AMD Southbridges

in reply to:  16 comment:17 by tonestone57, 9 years ago

Replying to Xbertl:

But I have the same problem on a fujitsu-siemens server mainboard with the Intel 440BX Chipset.
So I don't think that this is only a problem of my AMD SB600 and other AMD Southbridges

Well, your issue maybe the same. A serial debug log is required to see what is really going on. Ask on mailing list or forum. You cannot get serial log if boot failure happens early on. This ticket is impossible to fix without any debug log!

I have installed or tested Haiku on Intel boards - 440BX, Atom330, Core i3, on VIA KT600 & KT800, on Nvidia Nforce2, etc. and seen many others install to Intel & Nvidia boards. It is the AMD boards where you mostly & clearly see this booting issue happening pointing to boot loader, ATA stack (or south bridge) bug.

thatguy also noticed that, "Haiku [does not work] with certain dual cpu implementations of the old 440bx intel chipset on dual and single cpu P3 boards for whatever reason. I have tried a few and had 10 work and 2 not work." But without listing of hardware (lspci -nn in Linux) for failed systems, hard to tell what they have in common with your 440BX to at least pinpoint what hardware triggers no boot on those few BX boards.

http://www.haiku-os.org/community/forum/how_about_haiku_approved_motherboard#comment-18789

I see you have a ticket filed already but without debug log (serial or syslog) that bug will be unfixable. If you use Linux, do lspci -nn for 440BX board & attach to your ticket so we can view a device list.

comment:18 by Xbertl, 9 years ago

I already tried to get a serial debug output, but yes it happens to early :( .
(Yes I am sure that I do the serial connection the right way, because I tried it at first with a other pc)

comment:19 by mmlr, 9 years ago

It's not the SBx00 problem (or at least not the same one ;-) as that'd kick in far later in the boot process. As this is apparently a more generic problem I'd guess it comes from how we do early boot (i.e. switching protected mode on and off which is, while technically fine, not how most other boot loaders do it and hence has a chance of being untested/buggy with some BIOSes/hardware). It's quite difficult to debug such early boot problems as you can't get any debug output depending on how early it happens. Without having the hardware at hand to hand-debug the process it's unlikely to find the real cause.

comment:20 by umccullough, 9 years ago

Cc: umccullough added

comment:21 by stargatefan, 9 years ago

I will have a spare AM2+ cpu and Motherboard shortly. Has a AMD/ATI 7xx chipset with the symptoms described here. Would one of the devs want this board to test with ?? I don't mind so long as it gets returned. I think I may also have a dual cpu 440bx board and 2 cpus that could be tested with as well.

comment:22 by pulkomandy, 9 years ago

Blocked By: 4408 removed

comment:23 by pulkomandy, 9 years ago

Resolution: duplicate
Status: newclosed

Duplicate of #3441.

Note: See TracTickets for help on using tickets.