Opened 10 years ago

Closed 9 years ago

#5540 closed bug (fixed)

computer reboot in the haiku bootscreen

Reported by: AlienSoldier Owned by: axeld
Priority: critical Milestone: R1
Component: System/Kernel Version: R1/Development
Keywords: Cc:
Blocked By: Blocking:
Has a Patch: no Platform: x86

Description

Just before any icon light up, the computer just reboot. AOpen AX6BC EZ, it's a P3 system at 600Mhz right now. Haiku always worked well on it until now. At one point shutting down the computer in software worked but from many many revision i am not able to have the computer shut itself other than with the power switch, i don't know if it's related but it might be ACPI related so i mention it.

The reboot issue don't happen with haiku-nightly-hrev35718-x86gcc4hybrid-raw.zip, but it happen with hrev35731 and hrev35765 (i did not test those in between).

Change History (3)

comment:1 by AlienSoldier, 10 years ago

Just to add that i just tested with haiku-nightly-hrev35808-x86gcc4hybrid-raw.zip and the problem is still there. I guess i will enter haiku testing hibernation until this is fixed :)

comment:2 by AlienSoldier, 10 years ago

Ticket can be closed now, here is a little summary of what i done to fix this:

Last night i tested hrev35981 and it was still failing. I then decided to put it in another PC. There i was not seeing all the disk partition. I reinitialized in BFS the partition (with the hrev35718 that always worked on all PC) and decided to also do a make bootable on it (even if hrev35718 was working fine also when installed there). I was then able to see the partition and boot it.

I then moved that to the PC i want to use it on. It was still rebooting. I then just used one drive on it like it was on the other working PC, it then booted OK. So it seem that the boot menu on the master disk was not able to start my partition on my slave disk.

In any case, all seem fine now and it boot like before. As a happy ending, the PC can shutdown properly also now. So i guess some APM work between hrev35718 and hrev35981 was made.

comment:3 by mmadia, 9 years ago

Resolution: fixed
Status: newclosed

Took a while to close this, but thanks for the feedback!

Note: See TracTickets for help on using tickets.