Opened 9 years ago

Closed 7 years ago

#5715 closed enhancement (fixed)

Can't set native resolution

Reported by: DaaT Owned by: kallisti5
Priority: normal Milestone: R1/alpha4
Component: Drivers/Graphics/radeon_hd Version: R1/Development
Keywords: Cc:
Blocked By: Blocking:
Has a Patch: no Platform: All

Description

I can't set my laptop's native resolution. Got a new laptop a couple of weeks ago and it has an ATI Mobility Radeon 5650. The IDs are 1002-68C1. Native res is 1366x768 and the max I can choose is 1024x768.

Attachments (6)

radeonhd_syslog (20.4 KB ) - added by kallisti5 8 years ago.
syslog.old.zip (30.3 KB ) - added by DaaT 8 years ago.
Latest syslog obtained with hrev43328
syslog_12_02.zip (42.2 KB ) - added by DaaT 8 years ago.
syslog_rev43831.zip (30.2 KB ) - added by DaaT 8 years ago.
syslog_rev43831.2.zip (30.2 KB ) - added by DaaT 8 years ago.
IMG_20120313_190532.jpg (1.3 MB ) - added by DaaT 8 years ago.
rev43845 desktop

Download all attachments as: .zip

Change History (31)

comment:1 by DaaT, 9 years ago

Component: Preferences/ScreenDrivers/Graphics/radeon
Owner: changed from axeld to euan
Version: R1/alpha1R1/alpha2

In Alpha 2 Haiku still reverts to VESA.

comment:2 by anevilyak, 9 years ago

Owner: changed from euan to czeidler
Status: newassigned
Type: bugenhancement

This chipset is a Radeon HD, which is not covered by the current Radeon driver. Reassigning to Clemens since he's working on a driver for the HD chipsets currently.

comment:3 by X512, 9 years ago

Same problem with Mobility Radeon HD 3400 Series. Any progress?

comment:4 by czeidler, 9 years ago

Hi, I'm not working on the driver any more. The main problem was to read the EDID info from the monitor to be able to set all modes supported by the monitor. After contacting the xorg developer I found out that definitly ATOMBios is needed to do so. At this point Абдраимов Евгений contact me and said that he like to develop a radeon hd driver. So I haven't said no, developing driver is not that much fun for me. Lets see what he can achieve...

comment:5 by kallisti5, 9 years ago

Component: Drivers/Graphics/radeonDrivers/Graphics/radeon_hd

I have no clue what the status of Абдраимов Евгений's work is. created a new Trac category and am giving the AtomBIOS a whirl.

comment:6 by czeidler, 8 years ago

Resolution: fixed
Status: assignedclosed

kallisti5 is working on it, or it might already working. Close it for now.

comment:7 by anevilyak, 8 years ago

Resolution: fixed
Status: closedreopened

This one is still valid, please don't close them without verifying that they're in fact fixed.

comment:8 by anevilyak, 8 years ago

Owner: changed from czeidler to kallisti5
Status: reopenedassigned

comment:9 by kallisti5, 8 years ago

In looking at the Xorg Drivers for ati and radeon_hd, it seems they can function without the AtomBios parser (although this is untested on my end)

The problem using AMD's AtomBios is that it is *heavily* dependent on the Xorg video driver layout and takes quite a few Xorg style structs for video modes, pll timings, etc to function. I wish AMD was a little more open during their AtomBios parser creation to be more non-Xorg friendly.

Anyway, my work on having radeon_hd functional is ongoing and I *really* hope that after some fixes/tweaks to my PLL code we can have extended/non-vesa mode support for Radeon HD cards as a minimum. I feel the last thing not working is setting the pixel clock via PLL.

This Trac doesn't *have* to stay open as it's pretty general... but it really doesn't matter to me :P

by kallisti5, 8 years ago

Attachment: radeonhd_syslog added

comment:10 by kallisti5, 8 years ago

for those with too much time on their hands, the syslog output above shows the driver working on a Radeon HD 2400 (R610)

Only problem is the video is misaligned, you see stripes on some modes, and most lower modes don't work. This is all due to us not setting the PLL pixel clock properly yet (which is pretty important)

comment:11 by kallisti5, 8 years ago

post hrev42888 is working on earlier cards... however newer cards (5xxx+) are still broken.

verified this is still an issue.

comment:12 by kallisti5, 8 years ago

There are early reports of 5xxx cards working now. The 5350 I have for testing doesn't work however.

You may want to give it a try :)

comment:13 by DaaT, 8 years ago

Just tried the latest build available, hrev43238. Unfortunately, after the boot screen, there's a split second where the screen shows weird horizontal lines and after that only a black screen, no matter how long I wait.

by DaaT, 8 years ago

Attachment: syslog.old.zip added

Latest syslog obtained with hrev43328

by DaaT, 8 years ago

Attachment: syslog_12_02.zip added

comment:14 by DaaT, 8 years ago

This new syslog is from the latest nightly, hrev43375. Same behaviour as the previous try.

comment:15 by kallisti5, 8 years ago

the latest logs don't show any references to radeon_hd..

the nightly images may not have radeon_hd included.. this needs to be checked.

comment:16 by kallisti5, 8 years ago

the nightlies do have radeon_hd. It looks as though your logs didn't catch the driver init though.

A side note, this may be a potential issue due to #8329

comment:17 by kallisti5, 8 years ago

try post hrev43810. hrev43810 fixes a *big* oops.

by DaaT, 8 years ago

Attachment: syslog_rev43831.zip added

by DaaT, 8 years ago

Attachment: syslog_rev43831.2.zip added

comment:18 by DaaT, 8 years ago

Just tried rev43831 and the desktop is in colour but there's only the blue background and some thin horizontal lines crossing the screen (the Haiku menu) and if I move the mouse you can see a thin white horizontal line, about 5cms long, moving left and right.

I attached the syslog but don't know how much info is on it.

P.S.: Sorry for the duplicate syslog, my bad.

Last edited 8 years ago by DaaT (previous) (diff)

comment:19 by Disreali, 8 years ago

Thanks for the syslogs. However it would be more helpful if you did not zip them up and just attached them as plain text files.

comment:20 by kallisti5, 8 years ago

Daat: You're just a few commits too soon :)

Try hrev43833 or later.. I just made another fix that has a really high chance of fixing Radeon HD 5xxx and 6xxx mode setting issues.

comment:21 by DaaT, 8 years ago

Disreali, will do next time, was in space-saving mode :)

Kallisti, just booted back into windows and saw your latest commit! :D I'll test it as soon as possible and will let you know the results.

by DaaT, 8 years ago

Attachment: IMG_20120313_190532.jpg added

rev43845 desktop

comment:22 by DaaT, 8 years ago

Kallisti, just tried rev43845 but unfortunately the result's the same. I just attached a photo I took.

comment:23 by DaaT, 8 years ago

Just a quick update, same thing happens still with hrev43867.

comment:24 by DaaT, 7 years ago

Alex, good news. Ref 43900 did the trick! Haiku now boots into a beautiful 1366 (not multiple of 32 ;) ) by 768 screen. Thanks for all the hard work.

Last edited 7 years ago by DaaT (previous) (diff)

comment:25 by kallisti5, 7 years ago

Milestone: R1R1/alpha4
Priority: lownormal
Resolution: fixed
Status: assignedclosed
Version: R1/alpha2R1/Development

Glad to hear! :)

Closing

Note: See TracTickets for help on using tickets.