Opened 13 years ago

Closed 10 years ago

Last modified 10 years ago

#575 closed bug (fixed)

[SampleStudio] crash if you try to open a file

Reported by: diver Owned by: marcusoverhagen
Priority: normal Milestone: R1
Component: Kits/Game Kit Version: R1/pre-alpha1
Keywords: Cc: fredrik@…
Blocked By: Blocking:
Has a Patch: no Platform: All

Description

Attachments (1)

SampleStudio.txt (5.1 KB) - added by diver 13 years ago.
SampleStudio

Download all attachments as: .zip

Change History (13)

Changed 13 years ago by diver

Attachment: SampleStudio.txt added

SampleStudio

comment:1 Changed 13 years ago by marcusoverhagen

Status: newassigned

comment:2 Changed 13 years ago by marcusoverhagen

dependson: 332

comment:3 Changed 13 years ago by marcusoverhagen

BGameSoundDevice::Connect tries to instantiate a new audio mixer, which is bad. It should use the system mixer. This bug is probably caused by memory corruption done by BFileGameSound or BGameSoundDevice.

comment:4 Changed 11 years ago by korli

Platform: All

It's true the gamesound device mixing is based on an instanciated audio mixer. Mixing should be done internally before outputting to the system audio mixer.

comment:5 Changed 11 years ago by jackburton

Is this still valid ?

comment:6 in reply to:  4 ; Changed 11 years ago by jackburton

Replying to korli:

It's true the gamesound device mixing is based on an instanciated audio mixer. Mixing should be done internally before outputting to the system audio mixer.

Is this what GameProducer (in src/kits/game/GameProducer.cpp) should do ? We don't seem to use it, btw.

comment:7 in reply to:  6 Changed 11 years ago by jackburton

Replying to jackburton:

Is this what GameProducer (in src/kits/game/GameProducer.cpp) should do ? We don't seem to use it, btw.

Sorry, we ARE using it, indeed.

comment:8 Changed 10 years ago by diver

Component: - GeneralKits/Game Kit
Version: R1 development

comment:9 Changed 10 years ago by modeenf

Cc: fredrik@… added

Tested to load some mp3's and I had no problem, used Haiku hrev32595 and SampelStudio 1.0 B2.1.

Closing this if no one rejects. Other changes in here perhaps a new TODO or bug report?

I think I don't really understand what's need to be done here, but what's new :).

comment:10 Changed 10 years ago by diver

Can't reproduce it here too with SampelStudio 1.0 Beta 3.0. Feel free to close it.
BTW, anybody know why playing mp3 in SampelStudio does not skip at all when moving firefox around compared to VLC and MediaPlayer?

comment:11 Changed 10 years ago by modeenf

Resolution: fixed
Status: assignedclosed

is that the latest SampelStudio from bebits does it include the source? haikuware only have 1.0 Beta 2.1 :)

Closing this as fixed

comment:12 Changed 10 years ago by diver

I took it from BeMax4b1 /BeOS5PEMaxEditionV4b1/_packages_/SampleStudio/apps/SampleStudio.pk

Note: See TracTickets for help on using tickets.