Opened 9 years ago

Closed 9 years ago

Last modified 9 years ago

#5752 closed bug (fixed)

Network connection for broadcom570x fails to start after boot

Reported by: mbrumbelow Owned by: mmlr
Priority: high Milestone: R1/alpha3
Component: Drivers/Network Version: R1/alpha2
Keywords: broadcom570x Cc:
Blocked By: Blocking: #5891, #5893
Has a Patch: no Platform: x86

Description

Networking for the Broadcom card worked fine before this build (hrev36263).

HARDWARE:

  • Compaq 6710b laptop
  • broadcom570x network adaptor
  • iprowifi3945 network adaptor

OS:

Attachments (1)

Syslog.txt (164.4 KB) - added by mbrumbelow 9 years ago.
System log of the laptop from boot

Download all attachments as: .zip

Change History (17)

Changed 9 years ago by mbrumbelow

Attachment: Syslog.txt added

System log of the laptop from boot

comment:1 Changed 9 years ago by mbrumbelow

Version: R1/alpha1R1/Development

comment:2 Changed 9 years ago by mmlr

This might be an MSI issue, though there don't seem to be actual watchdog timeouts that are usually displayed in this case. Since there is currently no safemode option to turn MSIs off, could you try with a revision before hrev36225 and after that and check if that makes the difference.

comment:3 Changed 9 years ago by mbrumbelow

Yes, it's an MSI issue. Tested hrev36224 worked fine. hrev36225 and later releases are broken.

comment:4 Changed 9 years ago by hey68you

I'm having the exact same issue (it used to work for me on hrev36263). Same errors in syslog for me.

comment:5 Changed 9 years ago by mmlr

Blocking: 5891 added

(In #5891) Yes, most likely an MSI issue. Closing this as a duplicate of #5752.

comment:6 Changed 9 years ago by mmlr

Blocking: 5893 added

(In #5893) Yes, it's a duplicate.

comment:7 Changed 9 years ago by mmlr

Owner: changed from nobody to mmlr
Status: newin-progress

I'll look into blacklisting MSIs for the broadcoms then. I have a broadcom PCI card in use at home as well, though I haven't updated that machine yet. If I can reproduce it I might find out what the real issue is.

comment:8 Changed 9 years ago by xeon3d

did hey68you made a mistake when he referred to the used-to-work revision?

If it indeed stop working at hrev36225 how could it be working for him at hrev36263?

Are more syslogs needed? The OP's initial message was vague. I can define two clear sets of not working for me.

1 - Card shows up but doesn't get an ip address or work with a static one defined. 2 - Card doesn't even show up.

This is kinda a showstopper for me, since I can't really use my wlan.

comment:9 Changed 9 years ago by hey68you

Yes sorry xeon3d I made a mistake - the last version working for me was hrev35425 and I wasn't updating regularly. I then tried hrev36263 and that's where I saw this problem.

I'm also hoping for a quick fix!

comment:10 Changed 9 years ago by mmlr

Added a workaround in hrev36746. Needs proper fixing by moving the MSI enable somewhere else.

comment:11 Changed 9 years ago by mmlr

Interestingly FreeBSD does also disable in pci_setup_intr, which actually happens after the re-enabling of pinned interrupt generation by the driver, so I don't really get why it would work under FreeBSD at all.

comment:12 Changed 9 years ago by mbrumbelow

hrev36746 still is broken on my compaq laptop. No networking access, will revert back to working revision.

comment:13 Changed 9 years ago by hey68you

Working great for me on r1Alpha2 hrev36769 - thanks mmlr

(Writing this comment on WebPositive in Haiku !!!)

comment:14 Changed 9 years ago by mbrumbelow

hrev38769 works on laptop. Good job please close.

comment:15 Changed 9 years ago by jackburton

Resolution: fixed
Status: in-progressclosed

comment:16 Changed 9 years ago by xeon3d

Version: R1/DevelopmentR1/alpha2

I don't think this should be reopened as long as the underlying issue with MSI's is still there. If I recall correctly, there was a workaround added, and that's what fixed this.

I left as closed, so that someone higher in the hierarchy or the rest of the affected users could discuss and properly change the status.

Note: See TracTickets for help on using tickets.