Opened 9 years ago

Closed 9 years ago

#5776 closed enhancement (fixed)

Improve keyboard menu navigation

Reported by: andreasf Owned by: axeld
Priority: low Milestone: R1
Component: Kits/Interface Kit Version: R1/Development
Keywords: Cc:
Blocked By: #5996 Blocking:
Has a Patch: no Platform: All

Description

As discussed at BeGeistert, with the arrow keys you can enter a submenu or select a menu item, but you cannot leave the submenu again.

Expected behavior would be that the left arrow key selects the parent menu and right arrow the submenu (not the down arrow), on a left-to-right system.

Also, some menus can sometimes be left with the escape key but sometimes just unselect the submenu item but leave it open and arrow down reselects the first submenu item again.

Change History (6)

comment:1 Changed 9 years ago by mmadia

Component: - GeneralKits/Interface Kit
Owner: changed from nobody to axeld

comment:2 Changed 9 years ago by humdinger

Yep. Duplicate of #4930, right? :)

comment:3 Changed 9 years ago by andreasf

Blocked By: 5996 added

comment:4 Changed 9 years ago by stippi

It seems like this bug is fixed and #5996 was actually a dup? I don't know the deal with the Esc key sometimes working sometimes not. Do you want to keep the ticket open for now?

comment:5 in reply to:  4 Changed 9 years ago by andreasf

Has a Patch: unset

Feel free to close this one. @humdinger: I had asked whether there was already a ticket. ;)

comment:6 Changed 9 years ago by stippi

Resolution: fixed
Status: newclosed

Fixed in hrev36819.

Note: See TracTickets for help on using tickets.