Opened 10 years ago

Last modified 3 years ago

#5849 assigned bug

Tracker freezes if on desktop are a lot of files [+3000 and more]

Reported by: streak Owned by: nobody
Priority: normal Milestone: Unscheduled
Component: Applications/Tracker Version:
Keywords: Cc:
Blocked By: Blocking:
Has a Patch: no Platform: All

Description

Unintentially I unpacked FreePascal tar archive onto desktop [on hrev36511] and I spotted again strange tracker "freezing" behavior while i have more than +30 files on the desktop. Restarting not helps.

Only thing that helps is to delete files from desktop [ via terminal ], otherwise everytime you boot haiku, tracker will freeze after loading.

This is similar to Ticket #4617 but that was corrected , i believe..

Change History (11)

comment:1 by axeld, 10 years ago

Just for the record, I usually have more than 30 files on my desktop, and never experienced anything like this yet.

comment:2 by streak, 10 years ago

Tested and occurs on A2 too..

How to reproduce on R1A2:

Use Genesis Commander / BeFar, maximize it and copy a lot of files into desktop. Then minimize it. Desktop will freeze [ even replicants die aswell ]

comment:3 by scottmc, 9 years ago

Milestone: R1/alpha3R1/beta1

Need more details as I'm not able to see this. I dropped 800+ files on my desktop and track is still fine, so I suspect there is something else that is defective in your setup. Can you reproduce this on a recently nightly build without adding Genesis Commander, BeFar or any other programs to the mix?

comment:4 by pulkomandy, 8 years ago

Can't see any problem with 30+ files on desktop here either... Any news ?

comment:5 by nielx, 7 years ago

Closing issue for now. Original reporter: please reopen if you have more information about this issue.

comment:6 by nielx, 7 years ago

Resolution: invalid
Status: newclosed

comment:7 by pulkomandy, 6 years ago

Milestone: R1/beta1Unscheduled
Resolution: invalid
Status: closedreopened
Summary: Tracker freezes if on desktop are a lot of files [+30 and more]Tracker freezes if on desktop are a lot of files [+3000 and more]

Well, I just reproduced this, but I needed way more than 30 files. I had around 10000 debug reports saved from running WebKit testsuite (yes, it crashes quite a lot) on the desktop.

This leads to a very slow tracker, and some other apps randomly crashing. Trying to remove the files using the mouse (select some of them, and delete) leads to an app_server crash.

Reopening...

comment:8 by earl_colby_pottinger, 6 years ago

I believe this is the same problem I am having. Working on a compressing ram drive I found if I copy a large number files to the drive for test purposes that SYSLOG shows the slab manager constantly allocating memory, after about 30,000 files there is a low memory report, then after further copying a file cache error. After that files copy but the are constant error messages.

At this point there is no kernel memory free to run any programs. If I however, start up a program or two before I start copying. Then if I close those programs then Tracker will unfreeze.

It seemslike the file cache grows but never frees up memory if the resource get low.

I will post my SYSLOG later tonight.

comment:9 by bonefish, 6 years ago

I very much doubt that your issue is related. This ticket is about Tracker not being able to handle a lot of files on the desktop properly. What you report is a kernel level issue and it sounds like it is caused by your ram drive burning so much memory that the kernel is running short on memory or address space. Please open a separate ticket.

comment:10 by un_spacyar, 3 years ago

This ticket is still valid? I have about 48.000 files (420 Mb) of chiptune music inside a folder in the Desktop, and no issues detected (hrev50897 x86_gcc2)

comment:11 by axeld, 3 years ago

Owner: changed from axeld to nobody
Status: reopenedassigned
Note: See TracTickets for help on using tickets.