Opened 9 years ago

Closed 7 years ago

#5941 closed bug (fixed)

Tracker crash when right click with items selected

Reported by: oruizdorantes Owned by: axeld
Priority: high Milestone: R1
Component: Applications/Tracker Version: R1/Development
Keywords: tracker Cc:
Blocked By: Blocking:
Has a Patch: no Platform: All

Description

Revision: 34920 Slow system P3 1GHz.

Usually a right click with items selected. When the mouse sends more than 1 click event, and there seems to be a movement of position between these 2 events. Tracker seems to invoke 2 PopUpMenus.

In this situation Tracker crashes, Check attachment for backtraces

Attachments (3)

DoubleRightclickWithSomethingSelectedBug.txt (3.4 KB ) - added by oruizdorantes 9 years ago.
Backtraces gathered
TwoContextMenus.png (37.4 KB ) - added by jonas.kirilla 8 years ago.
TwoContextMenusWebPositive.png (30.2 KB ) - added by aldeck 8 years ago.

Download all attachments as: .zip

Change History (14)

by oruizdorantes, 9 years ago

Backtraces gathered

comment:1 by anevilyak, 9 years ago

Component: User InterfaceKits/libtracker.so
Owner: changed from stippi to anevilyak
Version: R1/alpha1R1/Development

comment:2 by aldeck, 9 years ago

I'm unable to reproduce, neither on real hardware nor virtualbox. The backtraces look strange to me and i suspect there might be another problem.

Concerning opening two menus at the same time, it reminds me a bug but it was fixed a long time ago.

If someone can still reproduce that would be appreciated :)

comment:3 by diver, 8 years ago

At least the last backtrace is still reproducible with hrev41847 in vbox.

by jonas.kirilla, 8 years ago

Attachment: TwoContextMenus.png added

comment:4 by oruizdorantes, 8 years ago

As note this was easily reproducible in slow machines. In my laptop which is a decent one I could not reproduce it.

comment:5 by aldeck, 8 years ago

I couldn't yet reproduce the crash, but as i suspected, the "two menus" issue is most certainly an BMenu / Interface Kit problem, as i could reproduce it in WebPositive, cf. screenshot. This is a fast machine, and there simply seems to be a voluntary delay in the BMenu tracking code, under a few hundred milliseconds even a left click outside the menu won't close it.

Still looking at the crash issue but i can't affirm the two problems are related.

by aldeck, 8 years ago

comment:6 by aldeck, 8 years ago

Could you retry? hrev41892 might help.

comment:7 by diver, 8 years ago

Still reproducible in hrev41892. See also #7059.

comment:8 by diver, 7 years ago

Component: Kits/libtracker.soApplications/Tracker
Owner: changed from anevilyak to axeld

comment:9 by leavengood, 7 years ago

By changing the Execution Cap for the CPU in VirtualBox to something pretty low (21% in my case, with a Core i7 host) I can easily reproduce the double context menus in Tracker. In fact I was able to get up to 5 at a time (in 5 different tracker windows.) I do not currently get a crash though. So maybe something changed in the mean time. Even when I had a selection and got two context menus in the same window I did not get a crash.

As for the general case of the double (or more) context menus, I imagine this should indeed be handled by the menu tracking code, which I've been complaining about again lately. I thought it might be something which could wait, but with issues like this (and I'm sure there are more), it might make sense to work on that now. I'm thinking of creating a BMenuTracker object as Stephan has suggested in the past. If that was some sort of per-application global object (or multiple instances with some static members) it could be sure not to open more than one context menu. With these VirtualBox settings I also got up to 6 context menus in WebPositive.

So I'm tempted to either close this issue or re-assign it to the Interface Kit. If someone else can reproduce the crash still, please add a comment with exactly how you reproduced it.

comment:10 by diver, 7 years ago

I can't reproduce this crash and none of #7059, but that might be hidden by #8818.

comment:11 by diver, 7 years ago

Resolution: fixed
Status: newclosed

Now that #8818 is fixed I still can't reproduce this one. Closing.

Note: See TracTickets for help on using tickets.