Opened 9 years ago

Closed 9 months ago

#5983 closed bug (not reproducible)

PANIC: did not find any boot partitions! (booting from USB on a notebook)

Reported by: SoonDead Owned by: mmlr
Priority: normal Milestone: R1
Component: Drivers/USB Version: R1/Development
Keywords: boot-failure Cc:
Blocked By: Blocking:
Has a Patch: no Platform: All

Description

When trying to boot from an USB device, while highlighting the middle icon, the following error pops up:

http://i39.tinypic.com/2vb23k8.jpg

It persists even after checking everything in safe mode, and after removing every other physical drive from the machine.

My machine is a Fujitsu-Siemens Amilo L1310G, BIOS Version is: 1.0F (17/05/2006)

Attachments (1)

haiku_lenovo_s10e.jpg (71.8 KB ) - added by solarflare 9 years ago.
Haiku hangs also on Lenovo S10e

Download all attachments as: .zip

Change History (11)

comment:1 by rcrodgers, 9 years ago

I'm getting the same error on a desktop PC. The motherboard in question is the Asus M2NBP-VM CSM which utilizes the NVIDIA Quadro NVS 210S north bridge and nForce 430B south bridge chipsets. I attempted to boot Haiku R1 Alpha 2 from a 1GB USB stick that I prepared the same day from the official "Anyboot" image. The exact same USB stick boots just fine in a Dell Studio 17 notebook based around Intel chipsets, so the USB stick and image appear to be fine.

by solarflare, 9 years ago

Attachment: haiku_lenovo_s10e.jpg added

Haiku hangs also on Lenovo S10e

in reply to:  description comment:2 by solarflare, 9 years ago

Version: R1/alpha2R1/Development

Replying to SoonDead:

When trying to boot from an USB device, while highlighting the middle icon, the following error pops up:

Same problem here, with Intel Atom machine Lenovo S10e. I wrote both R1/alpha2 and the nightly build version:

haiku-nightly-hrev39160-x86gcc2hybrid-anyboot.zip 143.62MB 9:38AM 27th October, 2010

with dd to the USB stick, booted them and landed automatically with them both into the KDL. I don't have a serial port in the laptop, but I'm able to make a HD video should any developer want to know the output of given commands, which would help figuring out what's wrong.

comment:3 by scottmc, 8 years ago

Blocking: 7665 added

comment:4 by Kenboo, 7 years ago

This instruction is just a help for new Haiku OS tester:

Current possible way to resolve this problem: just unplug all USB devices before boot haiku os. After boot the devices can be plug again.

Last edited 5 years ago by Kenboo (previous) (diff)

comment:5 by diver, 5 years ago

Component: - GeneralDrivers/USB
Owner: changed from nobody to mmlr
Platform: x86All

comment:6 by waddlesplash, 14 months ago

Keywords: boot-failure added; boot partition not found removed

comment:7 by waddlesplash, 14 months ago

Blocking: 7665 removed

comment:8 by waddlesplash, 9 months ago

Still an issue?

comment:9 by rcrodgers, 9 months ago

Well, I can't speak to the specific issue, but the latest anyboot image still doesn't boot on an AMD processor for me. In this case, a Ryzen 2400G processor, built-in GPU, 8 GB RAM, Asus Prime B350M-Plus Gaming motherboard. It got as far as but did not light up the chip icon during the boot process from a USB flash drive. I've more or less moved on and haven't been trying to work with Haiku for a while and only just caught the update email to this bug and thought I'd give it a shot.

comment:10 by waddlesplash, 9 months ago

Resolution: not reproducible
Status: newclosed

Well, that's a different issue (#13370) and using the EFI loader should work around it. Thanks for reporting back!

Note: See TracTickets for help on using tickets.