Opened 9 years ago

Closed 9 months ago

#6001 closed bug (invalid)

nvidia force_ws does not enable 16:9 modes

Reported by: tbe Owned by: rudolfc
Priority: normal Milestone: R1
Component: Drivers/Graphics/nVidia Version: R1/alpha2
Keywords: Cc:
Blocked By: Blocking:
Has a Patch: no Platform: x86

Description

Hi,

With my GeForce based ASRock K8NF4G-SATA2 motherboard, using the R1A2 release, the system freezes while loading the desktop unless I disable local apic in the boot menu.

With local apic disabled, it runs, but video falls back to VESA mode, which does not support my monitor's native resolution of 1920x1080. The motherboard has VGA as its only output, there is no DVI or second video port.

I have attached the syslog, listdev, listdev -d, and nvidia log.

The funny thing is that according to the nvidia log, the driver tries 1920x1080, but it concludes that the screen is not widescreen enough.

Cheers, Truls

Attachments (6)

syslog (79.0 KB ) - added by tbe 9 years ago.
listdev (3.2 KB ) - added by tbe 9 years ago.
listdev_tree (36.8 KB ) - added by tbe 9 years ago.
nvidia.10de_0242_000500.0.log (88.2 KB ) - added by tbe 9 years ago.
nvidia.10de_0242_000500.1.log (98.2 KB ) - added by tbe 9 years ago.
With force_ws true
nvidia.10de_0242_000500.2.log (102.7 KB ) - added by tbe 9 years ago.
1920x1080 available, but image is scaled incorrectly

Download all attachments as: .zip

Change History (17)

by tbe, 9 years ago

Attachment: syslog added

by tbe, 9 years ago

Attachment: listdev added

by tbe, 9 years ago

Attachment: listdev_tree added

by tbe, 9 years ago

comment:1 by tbe, 9 years ago

Please ignore syslog.2 and syslog.3.

They appeared because I did three attempts to upload the file when I got an error in WebPositive.

-Truls

comment:2 by mmadia, 9 years ago

Indeed. I deleted the attachments for you and added a note about this to wiki:R1/Alpha2/ReleaseAddendum#WebPositivereportserrorswhileuploadingfiles

comment:3 by Ziusudra, 9 years ago

Have you tried changing force_ws to true in nvidia.settings?

As for ACPI you can turn it off in home/config/setting/kernel/drivers/kernel. You might also see if #5982 applies.

by tbe, 9 years ago

With force_ws true

comment:4 by tbe, 9 years ago

Has a Patch: unset
Keywords: geforce vesa local apic removed
Summary: GeForce 6100 falls back to VESA modenvidia force_ws does not enable 16:9 modes

Apparently, the system was using the nvidia driver all the time, and never went back to vesa like I thought. After reading some hints in #4074, I see that "listimage | grep accel" shows nvidia.accelerant, and the Screen preferences panel has a Refresh rate drop down. I was confused because Screen preferences wrote a vesa file with the selected resolution, /dev/graphics/vesa existed, and I thought I had seen the screen use native resolution (although partly scrambled because of wrong refresh rate) before the local apic made it freeze.

This means that the local apic problem is entirely unrelated, so I will create a separate ticket for that.

I had already tried force_ws, and did not notice that it made any difference because it did not enable my native resolution, but I now see that it does enable some other modes.

Without force_ws, the dropdown in Screen preferences shows only 4:3 modes; 640x480, 800x600, 1024x768, 1152x864, 1280x1024, 1400x1050, 1600x1200, 1792x1344, 1856x1392, 1920x1440, 2048x1536.

With force_ws true, it adds these 16:10 modes; 800x500, 1024x640, 1280x768, 1280x800, 1440x900, 1680x1050, 1920x1200.

It still excludes the 16:9 modes; 1280x720, 1368x768, 1920x1080.

See the "screen at crtc2 is not widescreen (enough) type" lines in the two attached nvidia logs.

comment:5 by rudolfc, 9 years ago

Hi,

The last post is correct. I should update the driver so you can force 16:9 modes as well.

The autodetection fails because on your card the EDID/DDC channels detection fails. I can only fix that if I get access to such a non-functional card (integrated on mainboard being the problem here..) The hardware behaves a bit different from all other cards apparantly.

I'll have a look at the force_ws option.

Bye!

Rudolf.

comment:6 by rudolfc, 9 years ago

Status: newin-progress

Hi,

force_ws should now include 16:9 modes, since hrev37152. Please test and let me know.

Thanks!

Rudolf.

comment:7 by tbe, 9 years ago

Hi Rudolf,

I can confirm that 16:9 modes are now included, and I can select 1920x1080, but unfortunately there seems to be a problem somehow related to refresh rates.

I cannot seem to fine a refresh rate that makes the image correctly appear on the screen. With 60 Hz, which is supposedly the ideal frequency for my monitor, the image looks pretty good, but 270 pixels on the right hand side of the workspace are off screen so that the Deskbar is not visible. When switching to 70 Hz, the image looks more distorted. I now see the full width of the workspace, but 180 pixels on the bottom are off screen. Going any higher, and the screen starts acting funny, in different ways on different refresh rates. I also tried a few custom values, without much luck.

I'll attach a new log from the nVidia driver.

Here is a working modeline from Linux/X11 if that could be of any help:

"1920x1080" 148.50 1920 2008 2052 2200 1080 1084 1089 1125 +hsync +vsync

Thanks, Truls.

by tbe, 9 years ago

1920x1080 available, but image is scaled incorrectly

in reply to:  7 ; comment:8 by idefix, 9 years ago

Replying to tbe:

I cannot seem to fine a refresh rate that makes the image correctly appear on the screen. With 60 Hz, which is supposedly the ideal frequency for my monitor, the image looks pretty good, but 270 pixels on the right hand side of the workspace are off screen so that the Deskbar is not visible.

Did you try the auto-adjust function of your monitor?

I had the same problem (although not that severe: only 20 pixels on the right hand side cut off), but the auto-adjust function of my monitor fixed that.

in reply to:  8 comment:9 by tbe, 9 years ago

Replying to idefix:

Did you try the auto-adjust function of your monitor?

I've tried auto-adjust many, many times, with all the different configurations I have tried.

The image looks quite good, and no parts of the screen are black, but it must be stretched horizontally since part of the image is off screen.

Also note that the OSD tells me the refresh rate is 56.5 Hz when 60 Hz is chosen in the Screen prefs.

-Truls

comment:10 by rudolfc, 4 years ago

Hi,

The X11 mode line: "1920x1080" 148.50 1920 2008 2052 2200 1080 1084 1089 1125 +hsync +vsync

is exactly in the driver, so that's not the problem. (annymore?) Does this screen work correctly these days tbe?

Rudolf.

comment:11 by waddlesplash, 9 months ago

Resolution: invalid
Status: in-progressclosed

No reply in 3 years, closing.

Note: See TracTickets for help on using tickets.