Opened 9 years ago

Closed 9 years ago

#6054 closed bug (invalid)

Haiku Crashes when Laptop Lid is closed

Reported by: pjrinaldi Owned by: nobody
Priority: normal Milestone: R1
Component: - General Version: R1/alpha2
Keywords: Cc:
Blocked By: Blocking:
Has a Patch: no Platform: x86

Description

I close the laptop lid and to go do something. when i open it again, the os enters the KDL thing. the mouse doesn't work, but the keyboard does. The odd thing was that upon a reboot, my wireless network card wouldn't load in the network preferences and i couldn't get on the internet. after about 10 reboots, sometimes where it hangs on the Hard drive icon where i turn it off and back on again, and another crash when i closed the lid, the wireless network card showed back up and worked like normal. Not sure why it hangs on the hard drive boot icon, whether its doing an integrity check or something, but i couldn't figure out how to get out of graphical boot to look at the system messages.

I am using R1/alpha2 on an Acer Aspire Timeline 4810TZ laptop. My wifi card is atheros based and works great with the atheroswifi driver. i assume it has something todo with acpi and the lid closing. acpi is working new in this version and i can look at the battery display and the speedstep, but i assume sleep, hibernate, display off or display brightness are not implemented yet.

I don't know what information i should provide from kernel land or what to do with it or how to copy it from there other than writing it down on paper.

great work so far. other than the lid crashing, i haven't had a single crash or instability issue with the system so far.

Change History (3)

comment:1 by bonefish, 9 years ago

Yep, it's very like an ACPI related problem. As always in case of kernel crashes, the message printed after entering KDL is of interest as well as a back trace. Please have a look at the Kernel Bugs section of the Reporting Bugs page for more info.

comment:2 by pjrinaldi, 9 years ago

I tried recreating the bugs since the 2 or times it happened that one day. I have been unable to recreate it again. I have since redone my laptop and reinstalled Haiku R1/alpha2 to make Haiku my main OS and have not been able to recreate the issue once since that time. If I ever the get the issue to occur again, I will do the back trace and on screen messages and other information dumps from the kernel bugs section.

comment:3 by korli, 9 years ago

Resolution: invalid
Status: newclosed

Feedback welcome.

Note: See TracTickets for help on using tickets.