Opened 9 years ago

Closed 4 months ago

#6066 closed bug (fixed)

MediaPlayer interruptions, crash when system is maxed out.

Reported by: BeOSR Owned by: nobody
Priority: normal Milestone: R1
Component: Audio & Video Version: R1/alpha2
Keywords: Cc:
Blocked By: Blocking:
Has a Patch: no Platform: All

Description

When playing an MP3 file, it gets interruptions whenever there's disk access. When maxing the system by dragging a window about for some seconds, the playing stops and cannot be restarted. Loading another MP3 file does not work, neither does closing MediaPlayer on the desktop. It has to be force-quit from DeskBar (shift-ctrl-alt+click).

System: R1/alpha2 (rev 36769) GCC2 Hybrid

Running natively on this hardware: Intel Celeron 450 MHz IBM ATA HDD 15GB 383 MB RAM, 107 MB used Matrox G400Max 32MB

Change History (3)

comment:1 Changed 9 years ago by Garjala

I can confirm that it is very easy to crash Mediaplayer when CPU is maxed in singlecore system. Most of the time crashed Mediaplayer stays as zombie in the screen and has to be killed by force because it does not respond to anything anymore.

Tested in native hw: Athlon64 3200+, 2GB RAM, 120GB HDD, ATI Radeon X800 Pro, SB Audigy2

comment:2 Changed 6 years ago by harvard

When maxing the system by dragging a window about for some seconds, the playing doesn't stop and can be played again in Haiku R1/Alpha 4.1

comment:3 Changed 4 months ago by waddlesplash

Resolution: fixed
Status: newclosed
Note: See TracTickets for help on using tickets.