Opened 9 years ago

Closed 9 years ago

#6559 closed bug (fixed)

EeePC 4G - Intel Extreme driver

Reported by: jahaiku Owned by: pulkomandy
Priority: normal Milestone: R1
Component: Drivers/Graphics/intel_extreme Version: R1/Development
Keywords: Cc: gour@…
Blocked By: Blocking: #6570, #6690
Has a Patch: no Platform: x86

Description

Since hrev38363 and/or hrev38329 my EeePC 4G (800x480) shows a white screen after all the boot icons are shown OK. The build is a gcc4 build. Looks like "under the white screen" Haiku is booting OK.

Attachments (1)

syslog (8.1 KB ) - added by jahaiku 9 years ago.

Download all attachments as: .zip

Change History (19)

comment:1 by anevilyak, 9 years ago

Owner: changed from axeld to pulkomandy
Status: newassigned

comment:2 by pulkomandy, 9 years ago

I'd like a syslog.

  • Boot in "white screen mode" from a writable media (usb key or hard disk)
  • Reboot (hold control + alt + suppr down for 4 seconds)
  • When haiku boots again, press shift before the boot screen shows up to get to the boot menu
  • If you are lucky, you can save the syslog to an usb key directly in the boot menu
  • If not, you can boot in vesa mode ('Use fail-safe video mode') and get the syslog there (/boot/var/log/syslog).

What I'd like to see is what EDID settings were read from your screen by the driver.

in reply to:  2 ; comment:3 by jahaiku, 9 years ago

Replying to pulkomandy:

I'd like a syslog.

  • Boot in "white screen mode" from a writable media (usb key or hard disk)
  • Reboot (hold control + alt + suppr down for 4 seconds)
  • When haiku boots again, press shift before the boot screen shows up to get to the boot menu
  • If you are lucky, you can save the syslog to an usb key directly in the boot menu
  • If not, you can boot in vesa mode ('Use fail-safe video mode') and get the syslog there (/boot/var/log/syslog).

What I'd like to see is what EDID settings were read from your screen by the driver.

What do you mean with "suppr"-Key?

in reply to:  3 comment:4 by anevilyak, 9 years ago

Replying to jahaiku:

What do you mean with "suppr"-Key?

That would be "delete".

comment:5 by pulkomandy, 9 years ago

Yes,delete obviously. I'm using a french keyboard with french labels, sorry :).

comment:6 by stippi, 9 years ago

On behalf of jahaiku, I am attaching the following log (has written it down by hand):

init_hw() init_driver() (0) i915GM, rev=0x4 publish_devices() find_de.... loaded driver ....... open(name=graphics/intel_extreme_000200) intel_extreme_init() completed successfully accelerant: intel_extreme.accelerant getting EDID on port A (analog) failed: No Error(8) trying on port C (lvds) getting EDID on port C failed: No Error(8)

= Perhaps other important lines(shown many times):

DDC: ddc2_read(): DDC info read failure adpa: 40008c18, dova:0, dovb: 00480000, lvds: c0000300

comment:7 by stippi, 9 years ago

Sorry, one more try:

   init_hw()
   init_driver()
   (0) i915GM, rev=0x4
   publish_devices()
   find_de....(ich kann meine Schrift nicht mehr richtig lesen)
   loaded driver .......
   open(name=graphics/intel_extreme_000200)
   intel_extreme_init() completed successfully
   accelerant: intel_extreme.accelerant
   getting EDID on port A (analog) failed: No Error(8) trying on port C (lvds)
   getting EDID on port C failed: No Error(8)
=
Perhaps other important lines(shown many times):
   DDC: ddc2_read(): DDC info read failure
   adpa: 40008c18, dova:0, dovb: 00480000, lvds: c0000300

comment:8 by anevilyak, 9 years ago

Blocking: 6570 added

(In #6570) Duplicate of #6559.

comment:9 by jahaiku, 9 years ago

I have now attached a shortend syslog. Thanx to Stephan for adding the older one.

by jahaiku, 9 years ago

Attachment: syslog added

comment:10 by pulkomandy, 9 years ago

Ok, so the driver is failing to read the DDC info from your display panel to select the right resolution. I believe that also happens with older versions of Haiku. However, with the changes I made, the driver will set a default mode list and select a "random" mode from it whereas it used the mode set by VESA before. With the letterboxing I introduced, there is now a mixup when you try to select a mode bigger than your screen. Without DDC/EDID info, we can't know the actual screen size, so it's hard to tell when this will happen.

in reply to:  10 comment:11 by jahaiku, 9 years ago

Replying to pulkomandy:

Ok, so the driver is failing to read the DDC info from your display panel to select the right resolution. I believe that also happens with older versions of Haiku. However, with the changes I made, the driver will set a default mode list and select a "random" mode from it whereas it used the mode set by VESA before. With the letterboxing I introduced, there is now a mixup when you try to select a mode bigger than your screen. Without DDC/EDID info, we can't know the actual screen size, so it's hard to tell when this will happen.


How/why it worked before these two svn-updates?

Last edited 9 years ago by jahaiku (previous) (diff)

comment:12 by jahaiku, 9 years ago

To verify this I have exchanged mode.cpp with the version from hrev36941 and then it is working again.

Is it possible to change the new version in that way, that if all EDID is failing the old init code from hrev36941 is used?

comment:13 by pulkomandy, 9 years ago

Blocking: 6690 added

(In #6690) This is exactly the same as #6559. The old code was broken for other people, the new one is broken for you.

It should be possible to mix both to get something working for everyone.

comment:14 by gour, 9 years ago

Cc: gour@… added

comment:15 by diver, 9 years ago

Version: R1/alpha2R1/Development

comment:16 by pulkomandy, 9 years ago

Hello, Could you try hrev39081 or newer ? The old behaviour should be back in case both EDID reads failed.

Sorry for the delay.

in reply to:  16 comment:17 by jahaiku, 9 years ago

Replying to pulkomandy:

Hello, Could you try hrev39081 or newer ? The old behaviour should be back in case both EDID reads failed.

Sorry for the delay.


I have tested hrev39144 and it is working, again. Thanx.

comment:18 by pulkomandy, 9 years ago

Resolution: fixed
Status: assignedclosed
Note: See TracTickets for help on using tickets.