Opened 9 years ago

Closed 9 years ago

#6579 closed bug (fixed)

unable to build haiku due to ffmpeg/libavcodec bugs

Reported by: the ringmaster Owned by: bonefish
Priority: normal Milestone: R1
Component: Build System Version: R1/alpha2
Keywords: Cc:
Blocked By: Blocking:
Has a Patch: no Platform: All

Description

I can't seem to build the recent svn versions of haiku. I have tried clearing out my generated folders (I have 2 for the gcc4hybrid setup), and I've tried the "jam clean" to no avail.

Here is the terminal output: http://paste.org/pastebin/view/22260

Change History (3)

comment:1 Changed 9 years ago by the ringmaster

Use this paste instead: http://paste.org/pastebin/view/22261

comment:2 Changed 9 years ago by citi324

You may need to update you jam binary. I had the same problem, and this did the trick for me in Ubuntu:

svn up buildtools
cd buildtools/jam
jam
sudo cp ./bin.linuxx86/jam /usr/local/bin/jam

comment:3 Changed 9 years ago by stippi

Resolution: fixed
Status: newclosed

Yes, this problem has been fixed in svn, you need to rebuild and install the updated jam binary.

Note: See TracTickets for help on using tickets.