Opened 9 years ago

Closed 8 years ago

Last modified 8 years ago

#6652 closed bug (fixed)

[SATDecorator] clicking menubar switches to another window is a stack

Reported by: diver Owned by: czeidler
Priority: normal Milestone: R1
Component: Add-Ons/Decorators/Default Version: R1/Development
Keywords: Cc:
Blocked By: Blocking:
Has a Patch: no Platform: All

Description

This is hrev38756.
Stack Tracker window and Terminal together.
Clicking several times on File menu in the Tracker window will activate Terminal window.

Change History (14)

comment:1 by diver, 9 years ago

Still present in hrev39614.

comment:2 by diver, 9 years ago

This seems to be only with Terminal and tracker windows. Terminal window activates if you right click white area of tracker window .

comment:3 by diver, 9 years ago

Component: Servers/app_serverAdd-Ons/Decorators/Stack And Tile
Owner: changed from axeld to czeidler

comment:4 by czeidler, 8 years ago

Resolution: fixed
Status: newclosed

Fixed in hrev42487, thanks.

comment:5 by diver, 8 years ago

I can still reproduce it in hrev42487.

comment:6 by diver, 8 years ago

Resolution: fixed
Status: closedreopened

comment:7 by czeidler, 8 years ago

Don't believe that :) did you recompile everything? Previously all windows in the stack have been activated and thus you were able to click each window in the stack but now there is only the top layer window. Just tried it and can't reproduce it.

comment:8 by diver, 8 years ago

:-) Yes I did. I can try to capture video of it if you want.

comment:9 by czeidler, 8 years ago

Does tracker still flicker when clicking it? Anyway please delete app_server and SAT object files and compile again, really can't reproduced it... thanks

comment:10 by diver, 8 years ago

Resolution: fixed
Status: reopenedclosed

Ouch, sorry. Somehow I confused this ticket with #6616. This one is fixed for real, thanks!

comment:11 by diver, 8 years ago

Resolution: fixed
Status: closedreopened

It's back again in hrev42615.

comment:12 by czeidler, 8 years ago

Resolution: fixed
Status: reopenedclosed

Yes noticed this one :( hopefully fixed for a bit longer now!

comment:13 by diver, 8 years ago

Did you forgot to commit the fix into trunk, didn't you?

comment:14 by czeidler, 8 years ago

Forgot to enter my keyring password and then closed the terminal :)

Note: See TracTickets for help on using tickets.