Opened 13 years ago

Closed 11 years ago

#679 closed bug (fixed)

[app_server] crash with _numBlocks > 0

Reported by: diver Owned by: axeld
Priority: blocker Milestone: R1
Component: Servers/app_server Version:
Keywords: Cc:
Blocked By: Blocking:
Has a Patch: no Platform: All

Description (last modified by wkornewald)

While trying to reproduce #679, which in turn was found while trying to reproduce #630 i found another bug, eh :-)

app_server could crash if you type in Terminal /dev/random, and while it print lots of things try to play with selection. After several seconds app_server should crash. Tested under vmware with hrev17843. Back trace will follow.

Attachments (1)

app_server_crash_5.PNG (41.4 KB) - added by diver 13 years ago.
back trace

Download all attachments as: .zip

Change History (9)

comment:1 Changed 13 years ago by diver

dependson: 634

Changed 13 years ago by diver

Attachment: app_server_crash_5.PNG added

back trace

comment:2 Changed 13 years ago by axeld

* Bug 691 has been marked as a duplicate of this bug. *

comment:3 Changed 12 years ago by wkornewald

Description: modified (diff)
Platform: All

comment:4 Changed 12 years ago by axeld

Component: GeneralUser Interface/app_server

comment:5 Changed 12 years ago by stippi

Component: User Interface/app_serverKernel
Resolution: fixed
Status: newclosed

Looks more like an assert failed in malloc(), so I'm changing the component to "kernel".

comment:6 Changed 12 years ago by stippi

Component: KernelUser Interface/app_server

Ah never mind, I didn't follow all the discussion. Sorry.

comment:7 Changed 12 years ago by stippi

Resolution: fixed
Status: closedreopened

comment:8 Changed 11 years ago by axeld

Resolution: fixed
Status: reopenedclosed

I can't reproduce this, besides, it probably has been fixed since a while.

Note: See TracTickets for help on using tickets.