Opened 9 years ago

Closed 10 months ago

#6790 closed bug (duplicate)

screen_blanker don't restore on exit the active window

Reported by: phoudoin Owned by: nobody
Priority: normal Milestone: R1
Component: Servers/app_server Version: R1/Development
Keywords: screen_blanker Cc:
Blocked By: #9595 Blocking:
Has a Patch: no Platform: All

Description

To reproduce:

  1. set in Screensaver preflet a "Fade" corner and select whatever screensaver module
  2. memorize which window is active
  3. move mouse to Fade corner
  4. screen_blanker kick in
  5. move the mouse
  6. screen_blanker stop
  7. the previously active window is not active anymore
  8. there is *no* active window

Expected behaviour : the active window at screen saving enter should be restored as active window at screen saving exit.

Change History (3)

comment:1 by axeld, 9 years ago

Component: Add-Ons/Screen SaversServers/app_server
Keywords: screen_blanker added; screen_blank removed

Maybe the Desktop is active (you wouldn't see that). In any case, this has nothing to do with screen_blanker.

in reply to:  1 comment:2 by phoudoin, 9 years ago

Replying to axeld:

Maybe the Desktop is active (you wouldn't see that).

Well, if it is, it hasn't the keyboard focus at least.

In any case, this has nothing to do with screen_blanker.

Indeed, I figure out that while driving back home. Theorically any full screen window, even BDirectWindow ones, when destroyed the app_server should restore the previously workspace's active window. It doesn't. Maybe it's only for BDirectWindow, though.

comment:3 by waddlesplash, 10 months ago

Blocked By: 9595 added
Resolution: duplicate
Status: newclosed

Dupe of #9595, but that one has more info.

Note: See TracTickets for help on using tickets.