Opened 9 years ago

Closed 4 years ago

#6827 closed bug (fixed)

AboutSystem Crash

Reported by: netstar Owned by: axeld
Priority: normal Milestone: R1
Component: Servers/app_server Version: R1/Development
Keywords: Cc:
Blocked By: Blocking:
Has a Patch: no Platform: All

Description

When using different fonts than the default e.g VL Gothic, the AboutSystem dialogue will cause a system crash when you run the application.

Change History (6)

comment:1 Changed 9 years ago by jackburton

Is this with a recent revision ? I just tried with hrev39467 with VL Gothic and I got no crash. By the way, what do you mean with "System crash"? Can you give a backtrace or something ?

comment:2 Changed 9 years ago by diver

#4258 could be related. AFAIR AboutSystem with tahoma fonts randomly triggers app_server crash.

comment:3 Changed 9 years ago by diver

Component: - GeneralServers/app_server
Owner: changed from nobody to axeld

comment:4 Changed 9 years ago by phoudoin

While trying to reproduce this with hrev39887, it doesn't failed first time, but after changing 5-6 times the default fonts and reopen a few time AboutSystem, I too got app_server to crash.

It panic on "getNumAvailable() == 0" assert, with this backtrace:

debugger()
__assert_fail()
BPrivate::hoardHeap::findAvailableSuperblock()
BPrivate::threadHeap::malloc()
malloc()
realloc()
BList::_ResizeArray()
BList::BList()
Bgradient::BGradient()
BgradientLinear::BGradientLinear()
Bprivate::LinkReceiver::ReadGradiant()
ServerWindow::_DispatchViewDrawingMessage()
ServerWindow::_DispatchViewMessage()
ServerWindow::_DispatchMessage()
ServerWindow::_MessageLooper()
MessageLooper::_message_thread()
thread_entry()

comment:5 Changed 5 years ago by pulkomandy

I can't reproduce this, does it still happen?

comment:6 Changed 4 years ago by Janus

Resolution: fixed
Status: newclosed

I can't reproduce this either. Please reopen if you can. Thanks.

Note: See TracTickets for help on using tickets.