Opened 13 years ago

Closed 13 years ago

Last modified 13 years ago

#686 closed bug (fixed)

WindowLayer::IsNormal() crash

Reported by: johndrinkwater Owned by: axeld
Priority: normal Milestone: R1
Component: - General Version:
Keywords: Cc: diver
Blocked By: Blocking:
Has a Patch: no Platform: All

Description

app_server crashes in WindowLayer::IsNormal() with a Bad thread ID

Steps to reproduce: 1, load MrPeeps, and close it 2, load MrPeeps, and app_server should jump to fullscreen debug

It happens irregularly, so try to start MrPeeps again if it doesn't happen.

Change History (11)

comment:1 Changed 13 years ago by johndrinkwater

Note: this happens more often when you do not have people in your ~/people/ dir

comment:2 Changed 13 years ago by diver

Cc: diver added

comment:3 Changed 13 years ago by diver

Could this be somewhat connected to #653 ?

comment:4 Changed 13 years ago by axeld

Status: newclosed

comment:5 Changed 13 years ago by axeld

Resolution: fixed

comment:6 Changed 13 years ago by axeld

Thanks, I could reproduce this very well. Fixed in hrev17878.

comment:7 Changed 13 years ago by johndrinkwater

Diver, I hadn't found your bug on search because this was bad thread id, and not a segment violation, but maybe the same - the backtrace is nearly identical (with the exception of an additional Desktop::ActivateWindow), so it's possible. Best to retest.

comment:8 Changed 13 years ago by axeld

John, I'm afraid you're wrong here: "Bad thread ID" just means that GDB had some problems, the fault itself was a segment violation. "Bad thread ID" is just a standard error code.

comment:9 Changed 13 years ago by diver

blocked: 653

comment:10 Changed 13 years ago by johndrinkwater

Fair enough Axel (thankyou!), i'm still learning :) Does GDB lose all sense that it is a segment violation then? (will retest in a min)

comment:11 Changed 13 years ago by axeld

I don't know, it could be that it doesn't see the actual cause in this case, you'd have to ask Ingo if you want to know more :-)

Note: See TracTickets for help on using tickets.