Opened 9 years ago

Closed 9 years ago

#6880 closed bug (fixed)

[Terminal] Switch Terminals option is disabled

Reported by: diver Owned by: bonefish
Priority: normal Milestone: R1
Component: Applications/Terminal Version: R1/Development
Keywords: Cc:
Blocked By: Blocking:
Has a Patch: no Platform: All

Description

This is hrev39565 gcc4hybrid.

To debug several local problems I have Terminal in my bootscript. I noticed that if I start new Terminal it has Switch Terminals option disabled. To fix this I have to close all terminals and start new one.

Attachments (1)

bootscript.diff (446 bytes) - added by diver 9 years ago.

Download all attachments as: .zip

Change History (6)

Changed 9 years ago by diver

Attachment: bootscript.diff added

comment:1 Changed 9 years ago by diver

Err, I mean if I start new terminal from the one started from Bootscript...

comment:2 in reply to:  1 Changed 9 years ago by bonefish

Replying to diver:

Err, I mean if I start new terminal from the one started from Bootscript...

Works just fine for me. Tested with a gcc 4 build, but I don't see why that should make a difference. You don't have, by any chance, an older Terminal installed somewhere?

comment:3 Changed 9 years ago by diver

Nope, it's a clean image.

Last edited 9 years ago by diver (previous) (diff)

comment:4 Changed 9 years ago by bonefish

Owner: changed from jackburton to bonefish
Status: newin-progress

Seems to be reproducible only with non-DEBUG builds of Terminal. Looking into it...

comment:5 in reply to:  4 Changed 9 years ago by bonefish

Resolution: fixed
Status: in-progressclosed

Replying to bonefish:

Seems to be reproducible only with non-DEBUG builds of Terminal. Looking into it...

Actually it wasn't. It depended only on whether the settings file for the window positions was already there. Fixed in hrev39572.

Note: See TracTickets for help on using tickets.