Opened 8 years ago

Last modified 2 months ago

#6883 reopened enhancement

Open Containing Folder in Downloads does not work if directory is Desktop

Reported by: Coldfirex Owned by: jscipione
Priority: normal Milestone: R1
Component: Applications/Tracker Version: R1/Development
Keywords: Cc:
Blocked By: Blocking:
Has a Patch: no Platform: x86

Description (last modified by jscipione)

Howdy, I installed Haiku hrev39551 GCC2Hybrid in VirtualBox, and installed WebPositive (hrev545). I noticed that in the default Downloads location for WebPositive (Desktop), if you right click in the Downloads window and select 'open containing folder', it does not work correctly. It opens a window to the location if it is a directory besides the Desktop.

The bug was "fixed" when Tracker is Desktop Mode, in Spacial Mode it "works as intended"... still there remains one enhancement:

Figure out a good way to indicate that Desktop folder has been "opened" without opening a Tracker window.

Change History (20)

comment:1 Changed 8 years ago by Coldfirex

Maybe this is the intended design. If I go through the folder directories and open up the desktop folder it brings the actual Desktop to focus.

comment:2 in reply to:  1 Changed 8 years ago by anevilyak

Replying to Coldfirex:

Maybe this is the intended design. If I go through the folder directories and open up the desktop folder it brings the actual Desktop to focus.

That depends on whether you're using Tracker in single or multi-window mode. When in multi-window mode, it follows the spatial file manager paradigm that things like the old Mac OS Finder did, which indeed has the behavior you describe. When in single window mode, it will allow you to open the Desktop in a window as well. You can switch between them in Tracker's preferences.

comment:3 Changed 8 years ago by Coldfirex

Thanks for the explanation anevilyak. Out of curiosity I switched to single window mode, verified that the desktop folder would open as a folder and re-tested. The 'open containing folder' option in WebPositive still brought the Desktop to focus.

comment:4 Changed 8 years ago by anevilyak

Component: Applications/WebPositiveApplications/Tracker
Owner: changed from stippi to axeld

From a quick glance, TTracker::OpenContainerWindow() always searches for an open window in the current workspace matching the folder being requested first, and focuses that if found, regardless of single or multi-window browse mode. Given that the desktop window exists on all workspaces by definition, it will always receive focus instead of opening a new instance. The question is whether or not we want that behavior to change depending on the browsing mode or not. In any case, this is a Tracker issue rather than Web+ since the latter is sending the request correctly.

comment:5 Changed 8 years ago by tangobravo

In my opinion, Tracker should allow Desktop to open as a standard window regardless of the mode. The desktop itself is a bit special as it can never be brought in front of other windows. I wouldn't consider the Desktop being visible as being equivalent to having an open Tracker window of the desktop folder, so I think even in spatial mode I would expect a new window to open.

(Defaulting Web+ to /home/Downloads/ or something might be a good idea too.)

comment:6 Changed 8 years ago by aldeck

I think that we should just open a window until we find a better solution, i fear this is a fundamental problem of the Desktop paradigm.

Another solution would be to use a customized BPoseView in WebPositive so that you don't even need to open another window to interact normally with your downloaded files. This is not possible currently with libTracker but is something i've paved the way for in my tracker_layout branch.

comment:7 Changed 8 years ago by stippi

Another solution I would be perfectly happy with is displaying an alert in WebPositive which says that a particular file was downloaded to the Desktop. One drawback of this solution is that the file does not get selected in Tracker, which is probably the most useful aspect of the "Open containing folder" feature. Although the file should actually still get selected via Tracker messaging just fine.

comment:8 Changed 8 years ago by pulkomandy

Setting the default download folder to something else than the desktop would avoid the problem most of the time for Web+

Other OS using the desktop paradigm usually don't allow files on the desktop. GEM (Atari ST) has only volumes and the trash, Mac OS classic only allows alias to other files. This would also match our / better, since it allows the same.

comment:9 Changed 8 years ago by axeld

Another way would be to implement actually showing the desktop, ie. similar to what happens in Mac OS X when you press F11, or what happens in Windows when you press Win-D.

That functionality is currently missing from Haiku, anyway.

comment:10 Changed 8 years ago by humdinger

I don't know these Windows and MacOS functions, I assume they hide every window so you can see the Desktop. Personally, I always have at least one empty workspace that I can quickly switch to.
IMO, special casing the Desktop folder to be also openable in window mode makes most sense. Sometimes, I may want to see the Desktop in list view mode (if there are many files or I like to see file size or other attributes.

comment:11 in reply to:  10 Changed 8 years ago by bonefish

Replying to humdinger:

IMO, special casing the Desktop folder to be also openable in window mode makes most sense. Sometimes, I may want to see the Desktop in list view mode (if there are many files or I like to see file size or other attributes.

Fully agreed. I'd also like to see an item in the desktop's context menu to open the directory in a window -- well, or, even better, the browsing menu item could do that.

comment:12 Changed 8 years ago by axeld

I could live with that solution as well even though I like mine better :-)

comment:13 in reply to:  8 ; Changed 8 years ago by Disreali

Replying to pulkomandy:

Setting the default download folder to something else than the desktop would avoid the problem most of the time for Web+

NetPositive defaulted to /boot/home/Downloads for this reason. Special casing the Desktop add complexity where it is not needed.

comment:14 in reply to:  13 Changed 8 years ago by aldeck

Replying to Disreali:

NetPositive defaulted to /boot/home/Downloads for this reason. Special casing the Desktop add complexity where it is not needed.

That might be done anyway, but that would just be avoiding be problem for one application. We can't assume that no other program will want to write files in Desktop/ and ask Tracker to show the file. I'd be happy with the solutions proposed.

comment:15 Changed 8 years ago by stippi

I am undecided what the best default download location is. For a user completely new to the system, downloading to the Desktop makes sure the user doesn't have to search the file and that's why I implemented it this way, even though I was aware that NetPositive downloaded to /boot/home/Downloads. ~/Desktop is also the default in Firefox, probably for good reasons. On the other hand, it definitely forces a manual configuration, since things will get messy quickly. Ubuntu does have ~/Downloads, but it appears their Firefox package still defaults to downloading stuff to the Desktop. I would be Ok to change the default location in WebPositive and picking a default of ~/Downloads. This would be a very simple change to make in the WebPositive code, so please someone just go ahead. It would still be nice to be able to display the Desktop folder in a separate window for the reasons given here, and I believe we even discussed and agreed to this on the mailing list, in that discussion about where Trash and Desktop are located and whether they are created by Tracker when it first encounters a new BFS volume.

Last edited 8 years ago by stippi (previous) (diff)

comment:16 Changed 8 years ago by axeld

Personally, I always download to the desktop directly. For one, I don't have to look for the download location as the desktop is always there. And secondly, it prevents having a Downloads folder filling up with mostly superfluous files.

comment:17 in reply to:  16 Changed 8 years ago by bonefish

Replying to axeld:

Personally, I always download to the desktop directly. For one, I don't have to look for the download location as the desktop is always there. And secondly, it prevents having a Downloads folder filling up with mostly superfluous files.

Well, it fills up the desktop with mostly superfluous files instead. :-)

As far as I have noticed other OSs/browsers seem to move away from the downloading to the desktop, downloading to dedicated folder instead. *shrug*

comment:18 Changed 4 years ago by diver

Owner: changed from axeld to jscipione
Status: newassigned

comment:19 Changed 4 years ago by diver

Description: modified (diff)
Resolution: fixed
Status: assignedclosed

Fixed in hrev47342.

comment:20 Changed 2 months ago by jscipione

Description: modified (diff)
Resolution: fixed
Status: closedreopened
Type: bugenhancement
Note: See TracTickets for help on using tickets.