Opened 9 years ago

Closed 9 years ago

#6884 closed bug (duplicate)

Kernel Debugger in mediaplayer when playing several instances of same wav file

Reported by: Coldfirex Owned by: axeld
Priority: normal Milestone: R1
Component: System/Kernel Version: R1/Development
Keywords: Cc:
Blocked By: #5937 Blocking:
Has a Patch: no Platform: x86

Description

Howdy, I installed Haiku R39551 GCC2Hybrid in VirtualBox, and installed WebPostiive (hrev545). I started several instances of a small wav file (at least 10 or so) and was browsing in WebPostive perfectly. After a while I closed WebPositive and then I was sent to the kernel debugger. Strace and BT screenshots attached.

Attachments (1)

stack trace.JPG (120.3 KB) - added by Coldfirex 9 years ago.
strace

Download all attachments as: .zip

Change History (4)

Changed 9 years ago by Coldfirex

Attachment: stack trace.JPG added

strace

comment:1 Changed 9 years ago by stippi

Component: Applications/MediaPlayerSystem/Kernel
Owner: changed from stippi to axeld

Panics in KDL already contain the stack trace, no need to provide the "bt". This seems to be a kernel problem, there is no way for MediaPlayer to crash the kernel.

comment:2 Changed 9 years ago by phoudoin

I start to see one or two times similar KDL crash in read_port_etc() since few weeks too.

Maybe we have some hidden bug in port messages queue which show more often now? Or it's simply memory corruption from other part of the kernel code...

comment:3 Changed 9 years ago by bonefish

Blocked By: 5937 added
Resolution: duplicate
Status: newclosed

Duplicate of #5937.

Note: See TracTickets for help on using tickets.