Opened 13 years ago

Closed 11 years ago

#690 closed bug (fixed)

if the bootloader is interupted (by pressing the space bar) haiku is rebooting.

Reported by: kaoutsis@… Owned by: axeld
Priority: normal Milestone: R1
Component: System/Boot Loader Version:
Keywords: Cc: diver
Blocked By: Blocking:
Has a Patch: no Platform: All

Description (last modified by axeld)

if the bootloader is interupted (by pressing the space bar) to enter the bootloader menu, even if no changes made to the menu, after some disk activity (for about 2-3 sec) at the same time, the screen shows the logo, haiku is rebooting.

note that the bootvolume name has been discover successfullly.

Change History (13)

comment:1 Changed 13 years ago by diver

Cc: diver added

comment:2 Changed 13 years ago by axeld

Could you give at least *a bit* of additional information? Since it sure doesn't do this over here, I can't do anything with this bug description. Information needed would be: a) does Haiku boot successfully if you don't press the <spacebar>? b) at what point are you pressing that key? Is the logo already visible at that point? Or do you enter the boot menu without any problems, and just further booting from there doesn't work? c) what revision are you testing with? Did it always happen for you or did it started some time ago? d) what hardware are you testing with? Motherboard, IDE-Controller, HDs, RAM, BIOS version, CPU, etc. could all be useful.

Thanks.

comment:3 Changed 13 years ago by kaoutsis@…

Axel, thanks for your attention. After your guidelines

here are some answers: a)Yes, Haiku does boot successfully if i don't press the <spacebar>. b)The logo is not already visible at that point :) (Believe me, i press it, in time). I enter the boot menu without any problems, ( i may also change the default settings e.g checking the save mode options etc), and just further booting from there (with or without modifications to the boot menu) after some hard disk activity for about 2-3 and while a see the logo the system is rebooting. c) This problem did always happen for me, from the first time (3-4 months before) i start playing around with this machine (see bellow for details) and i know that the problem is specific for this machine since i have also a laptop and the problem does not occur. d) Some informations i gather for the machine: Processor Intel Pentim MMX 233 MHz System Buses ISA(16-bit), PCI(32-bit) System Bios Award 4.51 PG System Mainboard BIOSTAR Group (M5ATA) System Chipset Acer Labs Incorporated ALI M1531 ISA Bus ALI M1533 IDE Controller ALI M5229

RAM 104MB L2 External Cache 512 kB

ATA DISK drive ST34321A 8404830 sectors (4303 MB) w/128KiB Cache, CHS=523/255/63

CD/W drive TEAC CD-W540E

DVD-ROM drive SONY DDU1622

Isa Sound Card Creative ViBRA16C PnP Video Adapter ATI Rage II+ PCI (ati_m64)

and finally e) the same problem occurs to this machine when i created and a second partition with haiku installed.

that's all for now.

comment:4 Changed 13 years ago by axeld

Thanks for the info! While I haven't got a good idea what could cause this, this will definitely be helpful.

comment:5 Changed 13 years ago by olivier.coursiere@…

Oh ! My laptop experience this problem too... So, i answer the four questions too :

a) Yes, Haiku does boot successfully if i don't press the <spacebar>.

b) I press the <spacebar> just after pressing the <spacebar> in bootman. This machine is quite fast (at least from a beos point of view) : if you wait too much, Haiku will boot directly.

c) i use the lattest trunk from svn to compile haiku. I think (but unfortunately not sure) that haiku was not rebooting in this case about six months ago. But Haiku was not booting well on this machine too. That explain why i have tried the boot menu at that time.

d) Here some hardware informations :

ACER Aspire 1510

AMD 64 2200 Mhz Floppy drive : None (could it be related to this ? as this is the most "exotic" feature used in this machine)

RAM : 512 Mo CACHE L2 : 1024 kb

HDD Model Name : IC25N080ATMR04-0 (80 Go) Hitachi TravelStar ATAPI device : MATSHITADVD-RAM UJ-820S System bios version : S3A29 (PhoenixBIOS) VGA BIOS version : nVidia 04.36.20.33.D4 KBC version : 1A32

As it is a laptop (with fixed hardware), more details could be found using Google.

comment:6 Changed 13 years ago by oco

Platform: All

The problem is fixed for my laptop (tested with revision 18909)

comment:7 Changed 12 years ago by axeld

Component: System/KernelSystem/Boot Loader
Description: modified (diff)

comment:8 Changed 12 years ago by kaoutsis

A new testing: First i do: dd if=/haiku/beos/system/zbeos of=/dev/disk/floppy/raw booting from floppy, haiku goes directly to boot menu. Selecting haiku to boot. I select "Select safe mode options" and then "Enable on screen debug output" Haiku is not rebooting, but continue. Messages printed in my screen from debug output. The last message of this boot process is: bfs: mounted "be-src" (root node at ... etc) error starting "/bin/init" error = -1 In that point the boot process stopped.

Note that "be-src" is currently the last bfs partition of my disk.

Initialized an other partition with bfs and this volume has the name "test-vol" i do again the above process:

booting from floppy, haiku goes directly to boot menu. I select "Select safe mode options" and then "Enable on screen debug output" Haiku is not rebooting, but continue. Messages printed in my screen from debug output. The last message of this boot process is: bfs: mounted "test-vol" (root node at 65536, device = /dev/disk/ata/0/master/1_4) error starting "/bin/init" error = -1 In that point the boot process stopped.

For that i conclude that if the boot process is interrupted by pressing the space bar, to matter what, Haiku tries to mount as root partition the last bfs volume of the disk.

comment:9 Changed 12 years ago by kaoutsis

some updates:

  • the problem persists, not only to my old 233mmx, but also to the new p4 3Ghz

(the last one have also a plethora of bfs volumes.)

  • with hrev20414 i managed to boot normally to haiku; installed to test-vol,

which is the last bfs partition of the disk..., but from floppy!(dd if=zbeos of=/dev/disk/floppy/raw) And i can also select save mode options and boot with success. In other words, booting from floppy and selecting the last bfs volume of the disk to boot, everything is ok.

  • Another information i forgot to mention is that both systems are using grub 0.94

for boot manager.

comment:10 Changed 12 years ago by kaoutsis

more tests: on p233mmx i have two haiku bootable volumes, grub reports them as hd0,5 (named Haiku) and hd0,8 (named test-vol). i erased totally Haiku (initialized with drive-setup), test-vol enters bootmenu and then continues normally. If i erase test-vol, Haiku enters bootmenu and the continues normally. If both volumes have haiku complete installations, entering bootmenu either one reboots! So i may ask: does anyone has more than one haiku volumes, and can enter bootmenu, and from that point, successfully reaches the desktop to all haiku volumes?

comment:11 Changed 11 years ago by axeld

Can you retry with hrev23172? If it works now, then #1672 is a duplicate of this bug.

comment:12 in reply to:  11 Changed 11 years ago by kaoutsis

Replying to axeld:

Can you retry with hrev23172? If it works now, then #1672 is a duplicate of this bug.

i just did (hrev23182): boot menu is working fine now, (as far as i could tested); thanks! you can close this ticket.

comment:13 Changed 11 years ago by axeld

Resolution: fixed
Status: newclosed

Fixed in hrev23172 - duplicate #1672 contains the most useful info, though.

Note: See TracTickets for help on using tickets.