Opened 9 years ago

Closed 9 years ago

#7033 closed bug (invalid)

install anything from terminal results in gdb, BT included

Reported by: stargatefan Owned by: nobody
Priority: normal Milestone: R1
Component: - General Version: R1/Development
Keywords: Cc:
Blocked By: Blocking:
Has a Patch: no Platform: All

Description

install new optional sdllibs package results in GDB prompt and system crash. I have no idea where put this in the trac database.

warning: Lowest section in /boot/system/lib/libicudata.so.44 is .hash at 00000094 done. Loaded symbols for /boot/system/lib/libicudata.so.44 Reading symbols from /boot/system/lib/libicui18n.so.44...done. Loaded symbols for /boot/system/lib/libicui18n.so.44 Reading symbols from /boot/system/lib/libicuio.so.44...done. Loaded symbols for /boot/system/lib/libicuio.so.44 Reading symbols from /boot/system/lib/libicule.so.44...done. Loaded symbols for /boot/system/lib/libicule.so.44 Reading symbols from /boot/system/lib/libiculx.so.44...done. Loaded symbols for /boot/system/lib/libiculx.so.44 Reading symbols from /boot/system/lib/libicutu.so.44...done. Loaded symbols for /boot/system/lib/libicutu.so.44 Reading symbols from /boot/system/lib/libicuuc.so.44...done. Loaded symbols for /boot/system/lib/libicuuc.so.44 Reading symbols from /boot/system/lib/libtranslation.so...done. Loaded symbols for /boot/system/lib/libtranslation.so Reading symbols from /boot/system/lib/libroot-addon-icu.so...done. Loaded symbols for /boot/system/lib/libroot-addon-icu.so [tcsetpgrp failed in terminal_inferior: Invalid Argument] [Switching to team /boot/system/apps/Terminal (5640) thread w>Terminal 1: home: bash (5649)] 0x00244940 in TermWindow::_UpdateTitles () (gdb) bt #0 0x00244940 in TermWindow::_UpdateTitles () #1 0x00241d11 in TermWindow::MessageReceived () #2 0x00329b0f in BLooper::DispatchMessage () from /boot/system/lib/libbe.so #3 0x003f69ed in BWindow::DispatchMessage () from /boot/system/lib/libbe.so #4 0x003fac88 in BWindow::task_looper () from /boot/system/lib/libbe.so #5 0x0032b06b in BLooper::_task0_ () from /boot/system/lib/libbe.so #6 0x0084565a in thread_entry () from /boot/system/lib/libroot.so #7 0x700c1fec in ?? () (gdb)

Change History (14)

comment:1 by stargatefan, 9 years ago

warning: Lowest section in /boot/system/lib/libicudata.so.44 is .hash at 00000094
done.
Loaded symbols for /boot/system/lib/libicudata.so.44
Reading symbols from /boot/system/lib/libicui18n.so.44...done.
Loaded symbols for /boot/system/lib/libicui18n.so.44
Reading symbols from /boot/system/lib/libicuio.so.44...done.
Loaded symbols for /boot/system/lib/libicuio.so.44
Reading symbols from /boot/system/lib/libicule.so.44...done.
Loaded symbols for /boot/system/lib/libicule.so.44
Reading symbols from /boot/system/lib/libiculx.so.44...done.
Loaded symbols for /boot/system/lib/libiculx.so.44
Reading symbols from /boot/system/lib/libicutu.so.44...done.
Loaded symbols for /boot/system/lib/libicutu.so.44
Reading symbols from /boot/system/lib/libicuuc.so.44...done.
Loaded symbols for /boot/system/lib/libicuuc.so.44
Reading symbols from /boot/system/lib/libtranslation.so...done.
Loaded symbols for /boot/system/lib/libtranslation.so
Reading symbols from /boot/system/lib/libroot-addon-icu.so...done.
Loaded symbols for /boot/system/lib/libroot-addon-icu.so
[tcsetpgrp failed in terminal_inferior: Invalid Argument]
[Switching to team /boot/system/apps/Terminal (5640) thread w>Terminal 1: home: bash (5649)]
0x00244940 in TermWindow::_UpdateTitles ()
(gdb) bt
#0  0x00244940 in TermWindow::_UpdateTitles ()
#1  0x00241d11 in TermWindow::MessageReceived ()
#2  0x00329b0f in BLooper::DispatchMessage () from /boot/system/lib/libbe.so
#3  0x003f69ed in BWindow::DispatchMessage () from /boot/system/lib/libbe.so
#4  0x003fac88 in BWindow::task_looper () from /boot/system/lib/libbe.so
#5  0x0032b06b in BLooper::_task0_ () from /boot/system/lib/libbe.so
#6  0x0084565a in thread_entry () from /boot/system/lib/libroot.so
#7  0x700c1fec in ?? ()
(gdb) 






comment:2 by diver, 9 years ago

Component: - GeneralApplications/Terminal
Owner: changed from nobody to jackburton

comment:3 by bonefish, 9 years ago

You didn't include the line with the reason why the program crashed. It also doesn't harm to add the part of the syslog concerning the crash.

comment:4 by stargatefan, 9 years ago

It actually brought the system to its knees,I barely got this posted before it crashed. I think I might have a issue with some duplicated or overwritten librarys and files. I am going to do a clean install tonight reformat the drive and I will report back.

comment:5 by stargatefan, 9 years ago

Ok this started occurring as best as I can tell around version 39941 gcc2h, It seems to happen ANYTIME I install anything from terminal. It is not specific to sdllibs. This occurred while installing the bezilla browse. its the best I can offer you I barely avereted another horrific crash by killing terminal fast enough to capture this. It also sent my CPU temps skyward so I am lucky it didn't kill my cpu, power supply or motherboard. Thankfully I have thermal limiting in place on my motherboard.

Whatever is doing this is causes some nasty things to happen. Its worse with webpositive.

  GNU gdb 6.3
Copyright 2004 Free Software Foundation, Inc.
GDB is free software, covered by the GNU General Public License, and you are
welcome to change it and/or distribute copies of it under certain conditions.
Type "show copying" to see the conditions.
There is absolutely no warranty for GDB.  Type "show warranty" for details.
This GDB was configured as "i586-pc-haiku"...(no debugging symbols found)

[tcsetpgrp failed in terminal_inferior: Invalid Argument]
Thread 1736 caused an exception: Segment violation
Reading symbols from /boot/system/runtime_loader...done.
Loaded symbols for /boot/system/runtime_loader
Reading symbols from /boot/system/lib/libroot.so...done.
Loaded symbols for /boot/system/lib/libroot.so
[tcsetpgrp failed in terminal_inferior: Invalid Argument]
[Switching to team /bin/bash /bin/installoptionalpackage -a bezillabrowser (1736) thread bash (1736)]
0x00244754 in param_expand ()
(gdb) bt
#0  0x00244754 in param_expand ()
#1  0x002455d4 in expand_word_internal ()
#2  0x002467ce in shell_expand_word_list ()
#3  0x00246a19 in expand_word_list_internal ()
#4  0x002462f9 in expand_words_no_vars ()
#5  0x0022f6eb in execute_for_command ()
#6  0x0022d874 in execute_command_internal ()
#7  0x0022f43f in execute_connection ()
#8  0x0022d9d8 in execute_command_internal ()
#9  0x0022cf12 in execute_command ()
#10 0x0022f3ef in execute_connection ()
#11 0x0022d9d8 in execute_command_internal ()
#12 0x0022d9b9 in execute_command_internal ()
#13 0x002325c0 in execute_function ()
#14 0x00232a25 in execute_builtin_or_function ()
#15 0x00231c36 in execute_simple_command ()
#16 0x0022d722 in execute_command_internal ()
#17 0x0022cf12 in execute_command ()
#18 0x0022f8db in execute_for_command ()
#19 0x0022d874 in execute_command_internal ()
#20 0x0022f43f in execute_connection ()
#21 0x0022d9d8 in execute_command_internal ()
#22 0x0022d9b9 in execute_command_internal ()
#23 0x002325c0 in execute_function ()
---Type <return> to continue, or q <return> to quit---

comment:6 by stargatefan, 9 years ago

Summary: install sdl libs results in gdb, BT includedinstall anything from terminal results in gdb, BT included

in reply to:  5 ; comment:7 by luroh, 9 years ago

Replying to stargatefan:

It also sent my CPU temps skyward so I am lucky it didn't kill my cpu, power supply or motherboard. Thankfully I have thermal limiting in place on my motherboard.

If I were you, I'd run a stress test (perhaps grab a live CD like Inquisitor) to verify the general stability of your hardware. installoptionalpackage is pretty CPU intensive - that in combination with e.g. a CPU fan starting to cave in could possibly be the cause.

Its worse with webpositive.

What's worse with webpositive, the crash when trying to install it via installoptionalpackage?

in reply to:  7 comment:8 by bonefish, 9 years ago

Replying to luroh:

Replying to stargatefan:

It also sent my CPU temps skyward so I am lucky it didn't kill my cpu, power supply or motherboard. Thankfully I have thermal limiting in place on my motherboard.

If I were you, I'd run a stress test (perhaps grab a live CD like Inquisitor) to verify the general stability of your hardware. installoptionalpackage is pretty CPU intensive - that in combination with e.g. a CPU fan starting to cave in could possibly be the cause.

In principle it is possible that a kernel bug can cause such a behavior (random application crashes) -- most likely in the VM subsystem -- but there haven't been any significant changes for quite a while, and this is the only report of such problems I know of. So to me this also sounds very much like a hardware issue, particularly since you mention very high CPU temperatures. The OS is not responsible for keeping the CPU temperature in some range (I haven't read anything in this regard in the IA-32 specification yet at least), even if other OSs try to do that (and we should eventually implement that in Haiku, too).

Torturing the CPUs a bit, like luroh suggests, is certainly not a bad idea. If you have a Unixish system, a while true; do true; done per hardware thread should do the trick. If nothing else critical CPU temperatures should at least be logged somewhere (syslog/system messages).

comment:9 by bonefish, 9 years ago

Component: Applications/Terminal- General
Owner: changed from jackburton to nobody
Version: R1/alpha2R1/Development

comment:10 by stargatefan, 9 years ago

likely related

https://dev.haiku-os.org/ticket/7049#comment:2

I ran prime 95 on windows for 2 hours, memetest etc, I have a cooler master v8 180w cooler on a thuban phenom II x6 cpu 1055t model. Its only amonth old and tests out fine. everything is at stock clocking.

Test ram, HDD,MB,Power Supply, cooler etc.

this is all enclosed in a cooler master Cosmos case. idle cpu temp is 23c 45c fully loaded on handbrake under windows and 49c on prime 95.

I checked the machine out last night.

Problem did not exist at 39924.I tested at lurohs advisement. problem was not present, it is present in the mention 39943 however and its a gcc2 hybrid build.

Last edited 9 years ago by stargatefan (previous) (diff)

comment:11 by stargatefan, 9 years ago

I did some cache testing on my cpu after speaking with a developer friend of mine. There might potentially be a problem in the L2 cache for core 4 after testing. I am going to rma the cpu and report back in about 2 weeks.

comment:12 by stargatefan, 9 years ago

CPU is back, problem persist, ram and MB have been replaced.

comment:13 by stargatefan, 9 years ago

checked hardware again, oddly the problem was being cuased by a bios update that had been in place for sometime.

m4n78 pro bios update 1301 fixs "system instability" what exactly it fix's is unknown but the system never had problems before the last bios update of 1250 and the swap to the phenom II x6 cpu.

Go ahead and close this ticket.

Still wondering why I didn't notice this when I swapped in the x6 thuban cpu, but maybe I didn't boot into haiku for a while ?

go ahead and close it, I ran a bunch of instal tests etc from terminal, problem seems to be adressed.

comment:14 by korli, 9 years ago

Resolution: invalid
Status: newclosed

Thanks for the feedback.

Note: See TracTickets for help on using tickets.