Opened 8 years ago

Closed 4 years ago

Last modified 4 years ago

#7071 closed bug (duplicate)

Memory leak in app_server

Reported by: jonas.kirilla Owned by: axeld
Priority: normal Milestone: R1
Component: Servers/app_server Version: R1/Development
Keywords: Cc:
Blocked By: Blocking:
Has a Patch: no Platform: All

Description

Running the old Be Sample Code named "Whistle" and moving its sliders using either mouse or keyboard makes app_server gobble up memory which is not returned when the app quits.

I haven't been able to figure out exactly what gets leaked or exactly how it's triggered, but I have made a very stripped down version of Whistle which does trigger the leakage, most of the time. (on a quad core, fwiw) Run this and watch app_server's memory use rise.

http://www.kirilla.com/haiku/StrippedWhistle.zip

I think BeZillaBrowser triggers the same app_server memory leak, which can result in e.g. 500MB still used by app_server, having quit all apps.

Change History (4)

comment:1 Changed 8 years ago by jackburton

The whistle readme says: "A word of caution: Whistle's interface uses app server features that are largely untested, and uses them a lot. The interface *does* leak memory, but we're not sure where the leak is yet."

comment:2 Changed 8 years ago by korli

Could you please check if hrev40364 does also exhibit the bug? Thanks in advance.

comment:3 Changed 4 years ago by pulkomandy

Blocked By: 1713 added
Resolution: duplicate
Status: newclosed

comment:4 Changed 4 years ago by pulkomandy

Blocked By: 1713 removed

(In #1713) And I can't reproduce the leak anymore, either, so we can finally close this!

Note: See TracTickets for help on using tickets.