Opened 8 years ago

Closed 5 months ago

#7358 closed bug (fixed)

Expander's file panels isn't move to other workspace

Reported by: humdinger Owned by: nobody
Priority: normal Milestone: R1
Component: Servers/app_server Version: R1/Development
Keywords: Cc:
Blocked By: Blocking:
Has a Patch: no Platform: All

Description

This is hrev40812.

CTRL+ALT+CursorKeys switches workspaces, add SHIFT and you'll take the active window with you. Doesn't work with Expander's source/destination file dialogs, though. Those are left behind on the main window's workspace.

Does work with e.g. Pe, StyledEdit, ShowImage, DiskProbe etc.

Change History (5)

comment:1 Changed 8 years ago by korli

Expander use modals file panels. I tried to switch them to non modal and the behavior is then as expected.

Is a modal file panel supposed to switch workspace?

comment:2 Changed 8 years ago by axeld

Component: Applications/ExpanderServers/app_server
Owner: changed from korli to axeld

Modal windows are indeed handled differently to normal windows: they are supposed to always only appear where the application or its windows are. So obviously, something doesn't work out as intended :-)

comment:3 in reply to:  2 Changed 8 years ago by korli

Replying to axeld:

Modal windows are indeed handled differently to normal windows: they are supposed to always only appear where the application or its windows are. So obviously, something doesn't work out as intended :-)

OK. What would be the correct behavior then? Take the application windows and the modal window to the new workspace?

comment:4 Changed 2 years ago by axeld

Owner: changed from axeld to nobody
Status: newassigned

comment:5 Changed 5 months ago by humdinger

Resolution: fixed
Status: assignedclosed

Expanders filepanels now accompany their app window to another workspace. Fixed.

Note: See TracTickets for help on using tickets.