Opened 8 years ago

Last modified 5 months ago

#7465 reopened bug

[app_server] mouse wheel doesn't work for new windows until you move the mouse a bit

Reported by: diver Owned by: axeld
Priority: normal Milestone: R1
Component: Servers/app_server Version: R1/Development
Keywords: Cc: ttcoder
Blocked By: Blocking: #10472
Has a Patch: no Platform: All

Description

This is hrev41270, gcc4 hybrid.

Launch Installer and make sure that your mouse cursor is in the center of screen. When EULA screen shows up try to scroll it using mouse wheel.

Change History (9)

comment:1 by diver, 8 years ago

Summary: [Installer] scroll doesn't work at EULA screen until you move a mouse a bit[Installer] mouse wheel doesn't work at EULA screen until you move the mouse a bit

comment:2 by ttcoder, 6 years ago

Cc: degea@… added

Sounds like the (more general) app_server(?) bug I experience in Pe, in Tracker windows ..Etc. It's very easy to replicate e.g. in Pe: use the Alt-Tab combo to switch between a .cpp and .h window. Then use the wheel, without moving the mouse, the scroll will affect the window that was previously on top (i.e. the .cpp window if you've switched to the .h window). Or you can switch workspaces with Alt-Fx, going from a Tracker window to another (or to an app): moving the wheel will then scroll the window in the previous workspace, until you move the cursor by at least a pixel.

This won't occur so often with the mouse, because well.. it's hard to move the wheel without moving the mouse/cursor itself unless you try hard! But it occurs 100% when you use your laptop's touchpad (using the feature whereby you scroll by moving your finger on the very right edge of the touchpad) because in that case the mouse cursor has no reason to move.

Anyway, if others can confirm this is indeed a more general problem, component will have to be changed away from Installer clearly.

comment:3 by diver, 5 years ago

Component: Applications/InstallerServers/app_server
Owner: changed from korli to axeld

Can be also reproduced with CharacterMap.

comment:4 by diver, 5 years ago

Summary: [Installer] mouse wheel doesn't work at EULA screen until you move the mouse a bit[app_server] mouse wheel doesn't work for new windows until you move the mouse a bit

comment:5 by ttcoder, 5 years ago

Wow, boy does this one actually go way back! :-) I just stumbled on #762 .. Looks like an exact duplicate. The symptoms described there (launch AboutSystem from a Terminal window ..etc) work exactly, so it looks like the there was a regression after the fixes.

comment:6 by axeld, 4 years ago

Resolution: fixed
Status: newclosed

Fixed in hrev49183 -- it was not a duplicate of #762, and actually never worked correctly.

comment:7 by diver, 4 years ago

Resolution: fixed
Status: closedreopened

Nope, still doesn't work in hrev49189.

Tested with Installer and AboutSystem.

comment:8 by waddlesplash, 8 months ago

Blocking: 10472 added

comment:9 by ttcoder, 8 months ago

Cc: ttcoder added; degea@… removed

EDIT: all use paths seem to work great in R1/b1 ; which is odd, because nothing (?) has changed in years in relation to Desktop::_SendFakeMouseMoved(Window* window).... Will check some more and post a proper comment/notification proposing to close this.

Last edited 5 months ago by ttcoder (previous) (diff)
Note: See TracTickets for help on using tickets.