Opened 8 years ago

Closed 2 weeks ago

#7540 closed bug (invalid)

intsant reboot with HDDs attached

Reported by: tmmk3x Owned by: nobody
Priority: normal Milestone: R1
Component: System/Boot Loader Version: R1/Development
Keywords: boot-failure Cc:
Blocked By: Blocking:
Has a Patch: no Platform: All

Description

Hi, Haiku R1-alpha3-rc live cd (hrev41612) wont boot on my PC (real hardware) if I have any SATA HDDs connected to my computer. When trying to boot from CD I see the "loading dots" and after that, when the Haiku bootscreen should appear, the machine simply reboots.

Haiku boots fine from CD if I detach any HDD. An output of lshw under linux64 is attached.

Regards TM

Attachments (1)

lshw.txt (19.7 KB) - added by tmmk3x 8 years ago.
output of lshw

Download all attachments as: .zip

Change History (15)

Changed 8 years ago by tmmk3x

Attachment: lshw.txt added

output of lshw

comment:1 Changed 8 years ago by tmmk3x

Hi again. I tried debugging it a bit. First the bug is also present in the nightly hrev1/a3-rc (hrev41789). This time I tested the anyboot image on an external HDD (copied with dd). The image and HDD are fine, because it boots just fine on my atom/nvidia ion netbook. On my desktop it still reboots instantly when trying to boot it. I also cant get into the bootloader to enable serial output. (Yes my Desktop has one ;) ) Are there any images with serial output enabled by default so that I can test it further?

Regards TM

Last edited 8 years ago by tmmk3x (previous) (diff)

comment:2 Changed 8 years ago by tmmk3x

I managed to boot Haiku from CD. I had to switch the SATA Controller to legacy IDE mode. The bug seems to be related to this SATA controller. (its an SB700 controller). If you need anything just let me know. Regards TM

comment:3 Changed 8 years ago by diver

I believe serial output is turned off for all (pre)alpha images. Any image which filename starts with haiku-nightly* should have serial output enabled.

comment:4 Changed 8 years ago by tmmk3x

I tested the alternative MBR from #4028 with the same result. I also found out that the bug only occurs when the SATA controller (ATI SB700) is in RAID mode. AHCI also works fine. Is there a driver for RAID controllers or this controller in Haiku? I also noticed that Grub also has boot problems (doesnt find my kernel and/or boot partition from Linux). EXTLINUX is the Bootmanager i usually use. (works fine on my machine). Maybe its a problem with how Haiku accesses HDDs. Does it access HDDs like Linux (directly) or over the BIOS (like Windows)?.

comment:5 Changed 8 years ago by mmadia

Version: R1/alpha3R1/Development

R1 Alpha 3 has not yet been released. This was with an R1 Alpha 3 Release Candidate image.

comment:6 Changed 8 years ago by scottmc

Blocking: 7665 added

comment:7 Changed 8 years ago by bonefish

Please try trunk hrev42092 or newer. I added a debug facility that might catch the crash a provide a few debug infos.

comment:8 Changed 8 years ago by tmmk3x

Sry that it took me so long to answer. I tested trunk hrev42121 which I build from source myself (anyboot image). I tested it on my Netbook and hacking box (old AMD K7) to test if it runs ok. It worked but showed the same behaviour on my main system (see lshw.txt). While booting it shows "Loading system ..." on my screen and then reboots instantly like before. I also tried capturing debug messages via Serial connection (I verified with Linux that the physical connection is ok) but I only get two 0x00 per reboot but nothing from Haiku....

By the way is there a serial program for haiku that i can download freely or did I just didnt see it?

Last edited 8 years ago by tmmk3x (previous) (diff)

comment:9 Changed 4 years ago by diver

Component: - GeneralSystem/Boot Loader
Owner: changed from nobody to axeld
Platform: x86All

comment:10 Changed 2 years ago by axeld

Owner: changed from axeld to nobody
Status: newassigned

comment:11 Changed 9 months ago by waddlesplash

Keywords: boot-failure added; reboot hdd attached removed

comment:12 Changed 9 months ago by waddlesplash

Blocking: 7665 removed

comment:13 Changed 4 months ago by waddlesplash

Still an issue?

comment:14 Changed 2 weeks ago by waddlesplash

Resolution: invalid
Status: assignedclosed

No reply.

Note: See TracTickets for help on using tickets.