Opened 8 years ago

Closed 8 years ago

Last modified 8 years ago

#7939 closed bug (invalid)

Window doesn't get focus when behind windows of other apps

Reported by: jscipione Owned by: axeld
Priority: normal Milestone: R1
Component: Servers/app_server Version: R1/Development
Keywords: Cc:
Blocked By: Blocking:
Has a Patch: no Platform: All

Description

Open an app that draws into its view such as Charts or GLTeapot. Now open another app, any app really, I chose StyledEdit but it doesn't seem to matter much.

Place the window of the second app over the window of the drawing app so that it partially overlaps. Right click on the title bar of the window of the second app. This will make the app go behind the window of the drawing app. Now click anywhere on the partially visible first app bring it forward again.

The expected behavior is that the window of the second app will come forward in front of the drawing app window. The observed behavior is that the second apps's window remains behind the window of the drawing app.

Selecting the window of the second app in Deskbar will bring the window forward.

Change History (3)

comment:1 by jscipione, 8 years ago

Summary: Window doesn't get focus when behind windows of some other appsWindow doesn't get focus when behind windows of other apps

comment:2 by anevilyak, 8 years ago

Resolution: invalid
Status: newclosed

This was intentionally changed a few months ago ; the content area now no longer causes the window to come to the front, only the title bar does, the intention being to allow one to use controls in a window that's not at the front, as one can do in FFM mode, but without having to also accept FFM's general focus behavior.

comment:3 by axeld, 8 years ago

While this indeed was changed deliberately (although that particular outcome was merely a side effect), it doesn't mean it's the perfect solution yet -- see #7280.

It should actually be possible to get both aims implemented. In any case, this is a duplicate of #7630.

Note: See TracTickets for help on using tickets.