Opened 8 years ago

Closed 8 years ago

#8067 closed bug (duplicate)

Build broken: no matching function for call to BlockAllocator::CheckBlockRun

Reported by: Don Quixote Owned by: axeld
Priority: normal Milestone: R1
Component: System/Kernel Version: R1/Development
Keywords: bfs, BlockAllocator, filesystems, kernel, add-ons Cc:
Blocked By: #8065 Blocking:
Has a Patch: no Platform: x86

Description

This happened with the Subversion from yesterday, as well as with hrev42996 which I updated to just now.

src/add-ons/kernel/file_systems/bfs/BlockAllocator.cpp: In method `status_t BlockAllocator::Free(Transaction &, block_run)':

BlockAllocator.cpp:1051: no matching function for call to `BlockAllocator::CheckBlockRun (block_run &, NULL, NULL, bool)'

BlockAllocator.h:57: candidates are: status_t BlockAllocato::CheckBlockRun(block_run, const char * = 0, bool = true)

Attachments (1)

UserBuildConfig (557 bytes ) - added by Don Quixote 8 years ago.
The UserBuildConfig for the build that produced this error

Download all attachments as: .zip

Change History (2)

by Don Quixote, 8 years ago

Attachment: UserBuildConfig added

The UserBuildConfig for the build that produced this error

comment:1 by anevilyak, 8 years ago

Blocked By: 8065 added
Resolution: duplicate
Status: newclosed

Duplicate of #8065.

Note: See TracTickets for help on using tickets.