Opened 8 years ago

Closed 8 years ago

#8079 closed bug (fixed)

Resource uploading broken

Reported by: humdinger Owned by: deejam
Priority: normal Milestone:
Component: Website/Userguide Translator Version:
Keywords: Cc:
Blocked By: Blocking:
Has a Patch: no Platform: All

Description

It's not possible to add a new image or replace an existing image with a newer one any more. After providing the path for source and translation version, and selecting the picture, pressing the upload button sends the browser's progress bar off, but nothing really happens.

Change History (10)

comment:1 Changed 8 years ago by deejam

Owner: changed from VinDuv to deejam
Status: newassigned

comment:2 Changed 8 years ago by nielx

I actually cannot reproduce this problem. Humdinger, can you reproduce?

comment:3 Changed 8 years ago by humdinger

Component: Website/User Documentation TranslatorApplications/WebPositive
Priority: blockernormal

Hmm... you're right... At least with BeZilla it works, it doesn't with Web+ as it used to. I guess I'll change the component for this ticket to "Web+". Still, if deejam finds anything that might trip up Web+, I hope he can fix it. Our native browser should be able to deal with our translation site. I don't like BeZilla hat much anymore.

comment:4 Changed 8 years ago by deejam

Owner: changed from deejam to leavengood

Good to know! I'll reassign this ticket to Ryan.

comment:5 Changed 8 years ago by deejam

Component: Applications/WebPositiveWebsite/User Documentation Translator
Owner: changed from leavengood to deejam

I tested to replace an existing image with WebPositive in hrev43152 and it works.

humdinger: Can you verify again with a build that is not affected by #8101?

If that isn't the cause, I'll create a patch that sets action="" to a valid one. An empty value usually works, but WebPositive might not be that tolerant. In any case, I can't reproduce the error, so it's hard for me to debug.

<form enctype="multipart/form-data" method="post" action="">
<dl class="fieldset">
<dt><span>Upload new resource</span></dt>
<dd>
<label for="new_res">Upload file:</label> <input type="file" name="new_res" id="new_res" /><br/>
<input type="submit" value="Send File" />
</dd>
</dl>
</form>

I'm taking this back from Ryan and change the component back to User Documentation Translator until we are sure what's causing this.

comment:6 in reply to:  5 ; Changed 8 years ago by anevilyak

I wondered if this was due to #8101 myself, but this ticket was logged several days before the commit which caused that bug happened.

comment:7 in reply to:  6 Changed 8 years ago by deejam

Replying to anevilyak:

I wondered if this was due to #8101 myself, but this ticket was logged several days before the commit which caused that bug happened.

Yes I saw that. But I can't come up with anything else that can cause the problem.

Anyway, the empty form is fixed and verified to work in WebPositive in hrev43152. I changed both the form used to upload and re-upload resources.

I'll ask Niels to upload the changes.

comment:8 Changed 8 years ago by deejam

Changes uploaded by Niels. Everything works as expected for me (WebPositive, hrev43152). Humdinger, please test.

comment:9 Changed 8 years ago by humdinger

I updated to hrev43238 and uploading now works for me with Web+, too. Either it's the newer revision or your "action" magick was successful! Thanks very much in any case!

comment:10 Changed 8 years ago by deejam

Resolution: fixed
Status: assignedclosed
Note: See TracTickets for help on using tickets.