Opened 7 years ago

Closed 7 years ago

Last modified 6 years ago

#8241 closed bug (fixed)

Can't boot on Sandy Bridge PC.

Reported by: xeon3d Owned by: axeld
Priority: normal Milestone: R1
Component: System/Kernel Version: R1/Development
Keywords: sandy bridge, core, boot, stall Cc:
Blocked By: Blocking:
Has a Patch: no Platform: All

Description (last modified by diver)

Hi.

I've been trying to boot Haiku on my main machine with no success. The build I've tried is hrev43475 GCC2H off of haiku-files.org burned to a DVD.

Specs of the computer: Core i7-2700k (Sandy Bridge) Gigabyte GA-Z68X-UD4-B3 16 GB DDR3 RAM GeForce GT210 VGA (PCI-Ex) with 512 MB OCZ Vertex 3 SSD

Symptom: When booting normally, no boot icon lights up. I've tried booting with preety much every combination of safe mode flags to no availability. While booting verbose, the last lines it outputs before stalling (No KDL, nothing) are 7 lines similar to the ones that start with "PCI: dom 0, bus 0" in this photo: http://dev.haiku-os.org/attachment/ticket/8111/1.JPG

Extra Info: Due to my wanderings with booting multiple OSes, I've found a similar behaviour with OS X where it also stalls at "PCI Configuration". There was a fix provided by the developers which was to add a parameter to the bootloader, namely "npci=0x2000".

All the info I could find about that parameter is this tidbit

"0x2000 is the kIOPCIConfiguratorPFM64 flag, as seen in the IOPCIFamily source code. (PFM64 probably stands for prefetch memory 64 bit).

npci=0x2000 turns off this flag, as npci negates whatever flag bits you specify. With this flag turned off, the logic that sets fConsoleRange is disabled, and so the new graphics console relocation code is not triggered. However, the rest of the other new relocation code is still executed, and therein probably lies a problem for some, depending upon your PCI memory config."

Source: http://tonymacx86.com/viewtopic.php?p=222908#p222908

I've attached some logs from Linux (lspci, lsusb & lshw) since I was unable to get into KDL and not having a camera also didn't help regarding taking a picture of where it stalled.

Also, according to Disreali, this might be similar to the bug #8111 but since that one does go into KDL and mine doesn't (also, the user there is an AMD user and this is an Intel CPU) I thought it'd be better to create a new bug report.

Attachments (8)

lshw.log (3.9 KB) - added by xeon3d 7 years ago.
lshw log
lspci.log (2.8 KB) - added by xeon3d 7 years ago.
lspci normal log
lspci-full.log (57.5 KB) - added by xeon3d 7 years ago.
lspci extra verbose log
lspci-medium.log (19.8 KB) - added by xeon3d 7 years ago.
lspci normally verbose log
lsusb.log (845 bytes) - added by xeon3d 7 years ago.
lsusb log (doubt that it matters, but...)
IMG_3887.JPG (2.7 MB) - added by xeon3d 7 years ago.
Screen Debug Log with no debug options marked.
IMG_3888.JPG (2.1 MB) - added by xeon3d 7 years ago.
IMG_0003.jpg (896.6 KB) - added by Eddy 7 years ago.
KDL Sandy Bridge

Change History (22)

Changed 7 years ago by xeon3d

Attachment: lshw.log added

lshw log

Changed 7 years ago by xeon3d

Attachment: lspci.log added

lspci normal log

Changed 7 years ago by xeon3d

Attachment: lspci-full.log added

lspci extra verbose log

Changed 7 years ago by xeon3d

Attachment: lspci-medium.log added

lspci normally verbose log

Changed 7 years ago by xeon3d

Attachment: lsusb.log added

lsusb log (doubt that it matters, but...)

comment:1 Changed 7 years ago by xeon3d

Now that I think of it it might also be related to the integrated graphics card on the CPU.

comment:2 Changed 7 years ago by korli

Could you try to disable it in the BIOS to check this possibility?

comment:3 Changed 7 years ago by xeon3d

The motherboard doesn't really support any kind of integrated video, so it has no options to disable or enable it (or any options regarding it tbh). I mean, the cpu has on-board graphics but the board hasn't got any suitable connector to output video from.

But the architecture must probably take into account that most CPU's available for it have some kind of on-board video (there are 3 different ones I believe) so it probably accommodates for that. Since no other CPU Architecture from Intel has had integrated video on the CPU, probably something has changed regarding addressing or the PCI Bus.

Last edited 7 years ago by xeon3d (previous) (diff)

Changed 7 years ago by xeon3d

Attachment: IMG_3887.JPG added

Screen Debug Log with no debug options marked.

Changed 7 years ago by xeon3d

Attachment: IMG_3888.JPG added

comment:4 Changed 7 years ago by xeon3d

added 2 screen shots, the first one has no safe mode options enabled while the second one has all of them enabled. Mind the description on the IMG_3887 one.

Also, the graphics card on the system has been replaced with a Radeon HD6850 but that didn't change a thing.

Last edited 7 years ago by xeon3d (previous) (diff)

comment:5 Changed 7 years ago by mmlr

Looking at the logs and the pictures there are a couple of things to note:

  • There are a couple of PCIe ports with devices on them
  • There is a non-PCIe bridge (Intel) that hosts another non-PCIe bridge (ITE) that hosts the firewire controller
  • The picture shows the last bridge (PCIe port hosting external second Marvell SATA controller) was configured before things stop

That can mean a couple of things: It might mean that the problem is with that PCIe port or a device behind it. Or it might mean that the init of the bridges actually runs through but it's a device init that causes the stall. Or it might mean nothing and the reason is somewhere else entirely.

The only more exotic thing is the double PCI bridges for the firewire controller. What I'd try therefore is disabling firewire in the firmware if possible to see what changes in the device layout. Then I'd go for just disabling anything you can one by one (USB 3.0, USB 2.0, graphics, networking, ...). Note that xHCI doesn't do legacy support via companion host controllers, hence you can't use any of the USB 3.0 ports as we don't yet have a driver for that.

comment:6 Changed 7 years ago by xeon3d

mmlr, disabling USB 3.0 did the trick, it went past that bit at least but strangely it is now saying it can't find a bootable volume (I'm booting from CD). I'm going to try writing the image file to a USB stick and try it from there.

comment:7 Changed 7 years ago by xeon3d

Tried booting from a known working USB drive to no avail. I'll see if I can get a PS2 Keyboard so I can provide more details.

Don't know why but if I enable paging (so I can take photos of the on-screen debug log, the keyboard stops working after a while. I'm guessing it might have something to do with the usb detection bit as it seems it stops right after that bit.

comment:8 Changed 7 years ago by xeon3d

I was unable to get a PS/2 Adapter, but I compiled one of the latest revisions of Haiku straight to a hard disk partition and it booted (even tho I have to use fail safe vesa modes, but that was to be expected due to the GPU I have).

Sadly there were a lot more quirks after it booted such as:

  • Ethernet chip wasn't detected.
  • Wireless card didn't detect any networks (had the firmwares installed)
  • High pitched sounds on the speakers, muting or changing the volume did nothing.

Shall I open individual tickets for these? What info should I provide now that I can boot Haiku?

Also, what can I provide while booting from CD/USB to help diagnose why it doesn't find any boot partitions ?

comment:9 Changed 7 years ago by diver

Description: modified (diff)
Version: R1/alpha3R1/Development

comment:10 Changed 7 years ago by xeon3d

New information that might be relevant to the ticket.

I gave it a go on a newer revision tonight and here's what I found (with help from SMCollins on the IRC Channel)

As of rev 43989, I'm now unable to boot to Haiku unless I change the SATA controller to IDE/Legacy IDE (AHCI Driver Regression?).

Ethernet Chip is now detected, but still not working (keeps saying "Configuring...").

Wireless card status is the same (no networks detected), but I've since found it might be one of the cards that doesn't work with Haiku (dev id 4312)

Sound still has issues, even tho the High pitched sounds disappeared. It now seems to repeat endlessly a very small part of the sound (1 sec tops).

It happenned on a mp4 video played on MediaPlayer and if I dragged the duration slider near the end, the farther away I dragged it the less it'd happen. It stopped (everything, no stutter but no sound too) right near the end of the file (10 secs or so to finish the video).

SMCollins says something is wrong with my latency (on Cortex, Mediaplayer latency is 118.94ms and Mixer latency is 108.92ms), or the HDA driver is not compatible with the realtek codec in the motherboard (ALC889).

If I can provide any file to help diagonose the situation, please advise which.

Also, kudoz to Kallisti5 for a properly detected HD6850! :)

Changed 7 years ago by Eddy

Attachment: IMG_0003.jpg added

KDL Sandy Bridge

comment:11 Changed 7 years ago by Eddy

I have a Kernel Panic right after the boot sequence. My configuration is Shuttle SZ68R5 + Core i7 2600K + 16GB RAM + SSD 240GB Corsair GT. I always try it building the latest version of Haiku.

Last edited 6 years ago by mmadia (previous) (diff)

comment:12 Changed 7 years ago by diver

Resolution: fixed
Status: newclosed

@xeon3d, please open separate tickets about your ethernet/wireless/sound problems.
@Eddy, please file a new ticket under intel_extreme component with the attached image with additional info about your graphic card.

comment:13 Changed 7 years ago by anevilyak

Blocking: 8953 added

(In #8953) Duplicate of #8241.

comment:14 Changed 7 years ago by anevilyak

Blocking: 8953 removed

(In #8953) Erm, misread that one. Looks possibly related to #8533 though.

Note: See TracTickets for help on using tickets.