Opened 7 years ago

Closed 3 years ago

#8497 closed bug (fixed)

Deskbar will autoraise anytime you click on a area that is overlapped on top of it

Reported by: SeanCollins Owned by: nobody
Priority: normal Milestone: R1
Component: Applications/Deskbar Version: R1/Development
Keywords: Cc:
Blocked By: Blocking: #8522
Has a Patch: no Platform: All

Description

Deskbar will auto raise if you click on a object on top of Deskbar. If you park a Tab, window over deskbar and click on the area where deskbar riasides underneath, it will cuase deskbar to auto raise and steal mouse focus.

Attachments (3)

screenshot6.png (262.4 KB) - added by SeanCollins 7 years ago.
screenshot5.png (261.6 KB) - added by SeanCollins 7 years ago.
Deskbar_Steal_Focus.png (138.2 KB) - added by Giova84 6 years ago.

Download all attachments as: .zip

Change History (16)

Changed 7 years ago by SeanCollins

Attachment: screenshot6.png added

Changed 7 years ago by SeanCollins

Attachment: screenshot5.png added

comment:1 Changed 7 years ago by X512

I saw this bug too.

comment:2 Changed 7 years ago by anevilyak

Blocking: 8522 added

(In #8522) Duplicate of #8497.

comment:3 Changed 7 years ago by anevilyak

Version: R1/alpha3R1/Development

comment:4 Changed 7 years ago by anevilyak

Owner: changed from axeld to anevilyak
Status: newin-progress

comment:5 Changed 7 years ago by anevilyak

Resolution: fixed
Status: in-progressclosed

Fixed in hrev44112.

comment:6 Changed 7 years ago by anevilyak

Resolution: fixed
Status: closedreopened

Seems to have broken ctrl+alt dragging, investigating...

comment:7 Changed 7 years ago by anevilyak

Resolution: fixed
Status: reopenedclosed

(Hopefully) really fixed in hrev44113.

comment:8 Changed 6 years ago by Giova84

hrev45606 This bug seems still present: if a window is in front of the Deskbar (and auto-raise is activated) Deskbar will steal focus, this will also cause another issue: if i want to hide an app to full window mode by double click on his tab, i am unable to do this, since when i move the mouse on the tab, Deskbar will auto raise and will steal the focus. Also look at #9746 Screenshot attached.

Changed 6 years ago by Giova84

Attachment: Deskbar_Steal_Focus.png added

comment:9 Changed 6 years ago by Giova84

Resolution: fixed
Status: closedreopened

comment:10 Changed 6 years ago by Giova84

This will also happen with fullscreen apps (eg ShowImage and MediaPlayer) and the only way to avoid the Deskbar on front is to deactivate fullscreen, re enter in fullscreen mode and be careful to don't move the mouse where the Deskbar is placed, inside the fullscreen window.

comment:11 Changed 4 years ago by anevilyak

Owner: changed from anevilyak to nobody
Status: reopenedassigned

comment:12 Changed 3 years ago by SeanCollins

Fixed in latest nightlys, may have been fixed when John Scipone did the big deskbar rework

comment:13 Changed 3 years ago by diver

Resolution: fixed
Status: assignedclosed
Note: See TracTickets for help on using tickets.