Opened 7 years ago

Closed 9 months ago

#8656 closed bug (duplicate)

BMediaTheme "output frequency" entry is poorly placed

Reported by: Giova84 Owned by: yourpalal
Priority: normal Milestone: Unscheduled
Component: Kits/Media Kit Version: R1/Development
Keywords: mediapreferences output frequency entryis hidden Cc:
Blocked By: #11592 Blocking: #8851
Has a Patch: no Platform: x86

Description

Inside MediaPreferences, "output frequency" entry is hidden from the view. should be placed under "input frequency".

Look at the screenshot.

hrev44240

Attachments (1)

MediaPreferences.png (15.3 KB ) - added by Giova84 7 years ago.

Download all attachments as: .zip

Change History (8)

by Giova84, 7 years ago

Attachment: MediaPreferences.png added

comment:1 by Giova84, 7 years ago

Yes i see the scrollbar :-) But i see no sense to use the scrollbar since the "output" and "input" frequency could be aligned (and so more "clean").

comment:2 by diver, 7 years ago

Owner: changed from anevilyak to yourpalal
Status: newassigned

comment:3 by yourpalal, 7 years ago

Component: Preferences/MediaKits/Media Kit
Milestone: R1Unscheduled
Summary: MediaPreferences: "output frequency" entry is hidden from the view.BMediaTheme "output frequency" entry is poorly placed

This is actually not a problem with the Media preflet, since those views come directly from the Media Kit itself. IIRC, the views use a bunch of custom, pre-layout API stuff that should really be replaced. I'm willing to give guidance on this to anyone who takes it on, but it's not something I plan on doing.

If someone were interested, the relevant place to look would be at the Default Media theme .

comment:4 by diver, 7 years ago

How about reverting latest Media preflet changes where this bug, #8549 and #8659 didn't exist? they also made Media a bit preflet slower to appear and item selection is slower too.

Last edited 7 years ago by diver (previous) (diff)

in reply to:  4 comment:5 by yourpalal, 7 years ago

Replying to diver:

How about reverting latest Media preflet changes where this bug, #8549 and #8659 didn't exist? they also made Media a bit preflet slower to appear and item selection is slower too.

If you mean reverting hrev41781 then that would be ok, although I would be surprised if it would help. Reverting my other work (some major refactoring) would be a huge step backwards for the Media preflet, as I fixed a bunch of other GUI bugs and also majorly improved the code quality. We'd still have the issue of a buggy default media theme to boot.

As far regressions in speed, I don't think it's worth it to give up objectively better code for subjective speed enhancements.

comment:6 by diver, 7 years ago

Blocking: 8851 added

comment:7 by waddlesplash, 9 months ago

Blocked By: 11592 added
Resolution: duplicate
Status: assignedclosed
Note: See TracTickets for help on using tickets.