Opened 7 years ago

Closed 7 years ago

Last modified 7 years ago

#8899 closed bug (fixed)

[AboutSystem] Core i7-2640M is detected as Intel

Reported by: luroh Owned by: nobody
Priority: normal Milestone: R1
Component: Applications/AboutSystem Version: R1/Development
Keywords: Cc:
Blocked By: Blocking: #8951
Has a Patch: no Platform: All

Description

The CPU model in my x220 laptop is missing in AboutSystem and Pulse. Attaching a screenshot and the output of 'cat /proc/cpuinfo' from Linux.

Attachments (3)

screenshot.png (61.5 KB) - added by luroh 7 years ago.
cpuinfo.txt (3.5 KB) - added by luroh 7 years ago.
about.jpeg (33.1 KB) - added by dsjonny 7 years ago.

Download all attachments as: .zip

Change History (22)

Changed 7 years ago by luroh

Attachment: screenshot.png added

Changed 7 years ago by luroh

Attachment: cpuinfo.txt added

comment:1 Changed 7 years ago by diver

Component: System/KernelApplications/AboutSystem
Owner: changed from axeld to nobody
Summary: CPU model not recognized[AboutSystem] Core i7-2640M is detected as Intel
Type: enhancementbug

comment:2 Changed 7 years ago by lukove

i see too only "Intel" string -- i have Pentium G620 cpu

comment:3 Changed 7 years ago by axeld

Resolution: fixed
Status: newclosed

Should be fixed with hrev44619. Please report if the model name you see now is not okay.

comment:4 Changed 7 years ago by anevilyak

Blocking: 8951 added

(In #8951) Duplicate of #8899.

comment:5 Changed 7 years ago by dsjonny

This is the same problem in the Pulse app (there the CPU shows as unknown) for my Intel Core i3 2100T CPU (in the sysinfo that is 2106a).

comment:6 Changed 7 years ago by axeld

Yes, that's expected: they all use the same code to provide the name. Please retest with a newer revision.

comment:7 Changed 7 years ago by dsjonny

Currently I use hrevr1alpha4-44586. Is this fixed in the r1alpha4 versions too or only in the hrev44... builds?

comment:8 Changed 7 years ago by diver

The fix is not yet included in pre-alpha4 images. Try hrev44619 or newer.

Changed 7 years ago by dsjonny

Attachment: about.jpeg added

comment:9 Changed 7 years ago by dsjonny

Still problem in the latest hrevxxxxx image :(

This is the lates image in the http://www.haiku-files.org/haiku/development/ site. Where can I found hrev446xx image?

Last edited 7 years ago by dsjonny (previous) (diff)

comment:10 Changed 7 years ago by axeld

I don't know why the files are not being updated, but there is no need to attach a screenshot of an old revision that is known to be affected. If you notice a considerable lag (such as this) with the nightly images, a mail to the Haiku mailing list would be the best option.

comment:11 in reply to:  10 Changed 7 years ago by anevilyak

Replying to axeld:

I don't know why the files are not being updated, but there is no need to attach a screenshot of an old revision that is known to be affected. If you notice a considerable lag (such as this) with the nightly images, a mail to the Haiku mailing list would be the best option.

That's actually the newest nightly that's present, there are somewhat newer a4 images though (i.e. r1alpha4-44593). Something seems to be wrong, will see what I can find out, or in the worst case, ask Matt when he gets off work.

comment:12 in reply to:  10 ; Changed 7 years ago by mmadia

Replying to axeld:

I don't know why the files are not being updated, but there is no need to attach a screenshot of an old revision that is known to be affected. If you notice a considerable lag (such as this) with the nightly images, a mail to the Haiku mailing list would be the best option.

Since we're in release mode, the @nightly-* images from "master" are suspended. In their place are the @alpha-* images from the r1alpha4 branch. This is how it was handled in the previous releases.

comment:13 in reply to:  12 Changed 7 years ago by axeld

Replying to mmadia:

Since we're in release mode, the @nightly-* images from "master" are suspended. In their place are the @alpha-* images from the r1alpha4 branch. This is how it was handled in the previous releases.

While I think that it makes sense to make the alpha nightlies much more prominent, I don't think it's that a good idea to suspend the nightlies completely. Is it possible to make them available a bit more hidden? In some case it makes sense to give changes a test drive before merging them to the alpha branch.

comment:14 Changed 7 years ago by dsjonny

It is working now (for me) with the latest a4 image:

~> uname -a
Haiku shredder 1 hrevr1alpha4-44594 Sep 11 2012  BePC Haiku
~> sysinfo
Kernel name: kernel_x86 built on: Sep 11 2012 00:19:16 version 0x1
4 Intel Core™ i3-2100T, revision 86a7 running at 2494MHz (ID: 0x00000000 0x00000000)

Thank you for your help!

Last edited 7 years ago by dsjonny (previous) (diff)

comment:15 Changed 7 years ago by axeld

Thanks for the update!

comment:16 Changed 7 years ago by dsjonny

I do not want to open a new ticket for this. If I need, please inform me.

There is a CPU identity problem on a Samsung RV509 laptop. The CPU is: Intel Pentium, and Haiku show it as Intel Core i5.

This is the original string from the system log:

KERN: CPU 0: vendor 'Intel' model name 'Intel(R) Pentium(R) CPU        P6100  @ 2.00GHz'

comment:17 Changed 7 years ago by axeld

That output doesn't really help a lot. Could you please instead post the first few lines of a sysinfo output? Pretty like what you posted in comment:14.

comment:18 Changed 7 years ago by dsjonny

Sorry for the late...

~/Desktop> uname -a
Haiku shredder 1 hrevr1alpha4-44631 Oct 12 2012  BePC Haiku

~/Desktop> sysinfo
Kernel name: kernel_x86 built on: Oct 12 2012 00:51:16 version 0x1
2 Intel Core i5, revision 8655 running at 1994MHz (ID: 0x00000000 0x00000000)

CPU #0: "Intel(R) Pentium(R) CPU        P6100  @ 2.00GHz"

comment:19 Changed 7 years ago by dsjonny

And found another one:

Kernel name: kernel_x86 built on: Oct 12 2012 00:51:16 version 0x1
1 AMD Athlon 64, revision 8fc2 running at 1599MHz (ID: 0x00000000 0x00000000)

CPU #0: "AMD Sempron(tm) Processor 2800+"
Note: See TracTickets for help on using tickets.