Opened 7 years ago

Closed 6 years ago

#8901 closed bug (invalid)

USB-Stick problem

Reported by: Morbid Owned by: mmlr
Priority: normal Milestone: R1
Component: Drivers/USB Version: R1/Development
Keywords: Cc:
Blocked By: Blocking:
Has a Patch: no Platform: x86

Description

On problems as i've written in #8533, i decide to install Haiku to USB-Stick (Spaceloop by CnMemory 32GiB). Boot up the PC with Hama USB 2.0 Card Reader and hrev44555 on 2GiB SD-Card. Put in USB-Stick and he will be detect. Tried to format it with BeFS under DriveSetup and it shows me ISO9660 Filesystem and 27,5 GiB. Now, back to Windows and format it with Fat32 as primary Partition (no Errors). Back to Haiku start DriveSetup again and Stick was identified correctly. Than start the Installer and he tolds me "no partition have been found". Opened DriveSetup again, select USB-Stick and tried to format it with BeFS. On writing changes the LED of the Stick starts to blink permant and KDL pop up. Try to reproduce and get the Log. The same procedure as above with USB-Stick (Core by CnMemory 8GiB) and R1/alpha 3 works fine. Sorry for the length, but i want to give as much details as i can.

Attachments (11)

screenshot5.png (155.4 KB) - added by Morbid 7 years ago.
syslog_Spaceloop_CnMemory_32GiB.txt (318.8 KB) - added by Morbid 7 years ago.
syslog_after_mount_USB_32GiB.txt (125.8 KB) - added by Morbid 7 years ago.
syslog_after_mount_USB_32GiB.2.txt (125.8 KB) - added by Morbid 7 years ago.
syslog_after_mount_USB_32GiB.3.txt (125.8 KB) - added by Morbid 7 years ago.
KDL_Messages.txt (5.6 KB) - added by Morbid 7 years ago.
GDB_Message.txt (2.1 KB) - added by Morbid 7 years ago.
GDB_Message.2.txt (2.1 KB) - added by Morbid 7 years ago.
HD-Tune_CNMemory_32GB_1.jpg (80.4 KB) - added by Morbid 6 years ago.
HDTune_Error_Scan_CNMemory32GB_3.png (18.6 KB) - added by Morbid 6 years ago.
HD-Tune_Lexar_32GB_1.jpg (83.0 KB) - added by Morbid 6 years ago.

Download all attachments as: .zip

Change History (29)

comment:1 Changed 7 years ago by Morbid

New test with hrev44555 on USB-Stick (Core by CnMemory 8GiB). Partitioning, formating with BeFS, installing and booting works well, but used space is not correct!

Changed 7 years ago by Morbid

Attachment: screenshot5.png added

comment:2 Changed 7 years ago by anevilyak

What's not correct about it? Given how much RAM you have and Haiku's default swapfile size (2x RAM size) that looks about right to me.

comment:3 Changed 7 years ago by Morbid

Virtual Memory is deactivated and Swap-File at 0 Byte. System Memory is 4 GiB and USB-Stick 8 GiB. Hole Device formated as BeFS.

comment:4 Changed 7 years ago by anevilyak

/var/swap definitely doesn't exist? That makes no sense otherwise.

comment:5 Changed 7 years ago by Morbid

Swap-File under common Folder. Did not seen any other.

comment:6 Changed 7 years ago by Morbid

Only Haiku was installed and no other Software. Same Stick with R1/alpha3 shows me the correct size.

comment:7 Changed 7 years ago by anevilyak

Can you try running checkfs on that stick?

comment:8 Changed 7 years ago by Morbid

Have to try it tomorrow, because i gave the Stick to a college of me (Testing)! Sorry! Try to Test with 32GiB-Stick as written first. Could you tell me how to capture KDL, please!

Changed 7 years ago by Morbid

comment:9 Changed 7 years ago by bonefish

Component: Partitioning SystemsDrivers/USB
Owner: changed from bonefish to mmlr

comment:10 Changed 7 years ago by Morbid

Got the 8GiB Stick back! Colleague tell's me he have masiv bootproblems! Geting a new Stick (Core by CnMemory 8GiB) and there is everthing ok. Sorry and thanks for help!

comment:11 Changed 7 years ago by luroh

Morbid: I'm not sure I follow. Should this ticket be closed, or is there still a problem with your 32 GB stick?

comment:12 Changed 7 years ago by Morbid

The Problem still exist. Start a new try with r1alpha4 44631. Stick will detected but i can't format under Haiku. Format on Windows with Fat32 works. Back to Haiku and trying to mount the stick is leading to KDL. I don't know how i can send you the KDL-Message. Hope syslog is enough Info.

Changed 7 years ago by Morbid

Changed 7 years ago by Morbid

Changed 7 years ago by Morbid

comment:13 Changed 7 years ago by Morbid

Sorry for sending 3 times! Was a Problem with Web+

Changed 7 years ago by Morbid

Attachment: KDL_Messages.txt added

comment:14 Changed 7 years ago by Morbid

After first KDL-Message i use es command to leave. I wrote a small file in jpeg-format to the Stick and opened it with ShowImage. Than i closed all Windows and try to umount and after a view seconds the mount_server crashes.

Changed 7 years ago by Morbid

Attachment: GDB_Message.txt added

Changed 7 years ago by Morbid

Attachment: GDB_Message.2.txt added

comment:15 Changed 7 years ago by Morbid

Problem with 32GiB-Stick still exists on alpha4.1! At Info about that device there will be shown the Capacity of 0 Byte and jumps to KDL.

comment:16 Changed 6 years ago by Morbid

Have compared CnMemory 32GiB with a Lexar 32GiB-Stick. Tool was HD-Tune under Windows. Also tried both Sticks with my Sat-Reciver. The Reciver did not detect my CnMemory. Conspicuous: The CnMemory-Stick does not show the true size of 32GiB and at Benchmark some anomalies are occurred. Writing datas to the Stick works at Benchmark and under Windows. Lexar-Stick will be detected and works fine with Sat-Reciver, Windows and HAIKU!!! Please, take a look at the Screen-Shots. What do you think? Any Ideas?

Changed 6 years ago by Morbid

Attachment: HD-Tune_CNMemory_32GB_1.jpg added

Changed 6 years ago by Morbid

Changed 6 years ago by Morbid

Attachment: HD-Tune_Lexar_32GB_1.jpg added

comment:17 Changed 6 years ago by Morbid

Seems to be a Problem with the USB-Stick nor a PC or Haiku one. Think this Ticket can be closed. Thanks.

comment:18 Changed 6 years ago by korli

Resolution: invalid
Status: newclosed

Thanks for the feedback!

Note: See TracTickets for help on using tickets.