Opened 8 years ago

Closed 4 months ago

Last modified 4 months ago

#8982 closed bug (fixed)

Notifications are not shown

Reported by: dsjonny Owned by: pulkomandy
Priority: normal Milestone: R1/beta2
Component: Preferences/Notifications Version: R1/Development
Keywords: Cc:
Blocked By: Blocking: #7552
Platform: All

Description

The noticifications windows are not shown when the folder and application names are translated. When I turn this check off on the Local preferences panel, than it shows again.

Change History (18)

comment:1 by dsjonny, 8 years ago

Version: R1/alpha3R1/Development

comment:2 by dsjonny, 7 years ago

Using hrev46447 nightly anyboot this is still exists.

comment:3 by pulkomandy, 6 years ago

Blocking: 7552 added

comment:4 by pulkomandy, 5 years ago

Can't reproduce, is this still a problem?

comment:5 by dsjonny, 5 months ago

Still exists in hrev54115 x86_64. Tested by restarting the media server and also using the notify command in Terminal.

Not found related info in syslog.

comment:6 by diver, 5 months ago

Interestingly, I tried restarting the media server and notification do shows up here. Folder and application names are translated of course.

comment:7 by dsjonny, 5 months ago

Maybe it is local-related? Can you select other (hungarian) locale for testing?

comment:8 by dsjonny, 5 months ago

Tested with Polish locale and there was no problem. Strange :/

comment:9 by diver, 5 months ago

Reproduced with hungarian locale.

comment:10 by bitigchi, 5 months ago

Reproducible with Turkish locale.

comment:11 by waddlesplash, 5 months ago

PulkoMandy: Any chance you will be able to look into this while "polishing" for beta2?

comment:12 by pulkomandy, 5 months ago

I had asked about this before merging the "enable localizations by default" because it was a known problem. I suggest we revert that until the issue is fixed. Unless there is a better plan. I wouldn't even know where to look for this, there is no reason for this setting to have any effect on notifications, right?

comment:13 by waddlesplash, 5 months ago

Well, it seems related to the notification server and locales, so probably the place to start is investigating if the notification server is getting the notification requests, and then go backwards or forwards from there?

I suspect that this is related to B_TRANSLATE_SYSTEM_NAME breaking something inside notification_server or the like. Hence why it would be better for someone familiar with the Locale Kit to investigate.

comment:14 by pulkomandy, 5 months ago

I did not write the B_TRANSLATE_SYSTEM_NAME code and don't know how it works. You're as familiar as me with this part.

comment:15 by X512, 5 months ago

I identified problem. BDeskbar::Frame() that is used to calculate position of notification window do not work if Deskbar window name is not "Deskbar". It use Deskbar window name to find window: https://git.haiku-os.org/haiku/tree/src/kits/interface/Deskbar.cpp#n46. Deskbar use localized window name: https://git.haiku-os.org/haiku/tree/src/apps/deskbar/BarWindow.cpp#n88.

So notifications are displayed, but outside of screen. Notification window can be visible in Workspaces app on upper left side of workspace.

Last edited 5 months ago by X512 (previous) (diff)

comment:16 by waddlesplash, 4 months ago

Resolution: fixed
Status: newclosed

Fix merged in hrev54146. Thanks for investigating!

comment:17 by nielx, 4 months ago

Assign tickets with status=closed and resolution=fixed within the R1/beta2 development window to the R1/beta2 Milestone

comment:18 by nielx, 4 months ago

Milestone: R1R1/beta2
Note: See TracTickets for help on using tickets.