Opened 7 years ago

Closed 7 years ago

Last modified 7 years ago

#8983 closed bug (duplicate)

Haiku hangs up when booting in live version

Reported by: olafito18 Owned by: axeld
Priority: normal Milestone: R1
Component: System/Kernel Version: R1/alpha3
Keywords: phenom x4 965 amd c1e Cc:
Blocked By: #3999 Blocking:
Has a Patch: no Platform: x86

Description

When trying to boot Haiku it freezes.

I take pictures of the debug screen. It seems to be a problem with the cpu because Haiku only detects 3 cores. When I disable "local APIC" i was able to boot completly.

It's a AMD Phenom X4 965 with 4 GB of RAM.

The motherboard is ASUS

I upload more details in files

First image: I get it pushing ESC key in boot.

Second image: Debug message

Third image: Debug message continuation and freeze

Attachments (5)

SDC13839.JPG (448.3 KB) - added by olafito18 7 years ago.
I get this pushing ESC key at boot
SDC13856.JPG (443.5 KB) - added by olafito18 7 years ago.
Debug messages
SDC13855.JPG (208.7 KB) - added by olafito18 7 years ago.
Debug messages continuation and freeze
cpu info (3.6 KB) - added by olafito18 7 years ago.
Cpu details in /proc/cpuinfo in GNU/Linux (same machine)
lspci (2.4 KB) - added by olafito18 7 years ago.
List of PCI devices (lspci in GNU/Linux)

Download all attachments as: .zip

Change History (11)

Changed 7 years ago by olafito18

Attachment: SDC13839.JPG added

I get this pushing ESC key at boot

Changed 7 years ago by olafito18

Attachment: SDC13856.JPG added

Debug messages

Changed 7 years ago by olafito18

Attachment: SDC13855.JPG added

Debug messages continuation and freeze

Changed 7 years ago by olafito18

Attachment: cpu info added

Cpu details in /proc/cpuinfo in GNU/Linux (same machine)

Changed 7 years ago by olafito18

Attachment: lspci added

List of PCI devices (lspci in GNU/Linux)

comment:1 Changed 7 years ago by augiedoggie

Are you really using Alpha3 or a nightly build? This looks like the C1E issue described in tickets #3999,#7478,#8456,#8085,..... and so on

comment:2 in reply to:  1 ; Changed 7 years ago by olafito18

Replying to augiedoggie:

Are you really using Alpha3 or a nightly build? This looks like the C1E issue described in tickets #3999,#7478,#8456,#8085,..... and so on

Yes, I'm using Alpha3.

Let me try disabling C1E and return here to post answers.

comment:3 in reply to:  2 ; Changed 7 years ago by umccullough

Replying to olafito18:

Yes, I'm using Alpha3.

Or, just try a recent nightly, or alpha4 candidate release from here: http://www.haiku-files.org/haiku/development/

comment:4 in reply to:  3 Changed 7 years ago by olafito18

Replying to umccullough:

Replying to olafito18:

Yes, I'm using Alpha3.

Or, just try a recent nightly, or alpha4 candidate release from here: http://www.haiku-files.org/haiku/development/

Ok, I tested the last nightly build and the problem is not present. Now the system boots fine even with C1E enabled.

Thanks and sorry for the duplicated issue.

Last edited 7 years ago by olafito18 (previous) (diff)

comment:5 Changed 7 years ago by anevilyak

Blocked By: 3999 added
Keywords: c1e added
Resolution: duplicate
Status: newclosed

comment:6 Changed 7 years ago by anevilyak

Platform: x86-64x86
Note: See TracTickets for help on using tickets.