Opened 7 years ago

Last modified 11 months ago

#9028 reopened bug

GLTeapot Performance Issues under swrast add-on

Reported by: Premislaus Owned by: nobody
Priority: normal Milestone: R1
Component: Kits/OpenGL Kit/Software Rasterization Version: R1/Development
Keywords: GLTeapot one core not responsive 100% CPU usage Cc:
Blocked By: Blocking:
Has a Patch: no Platform: All

Description

On hrevr1alpha4-44610 GLTeapot uses 100% cpu( previous revisions also - gcc4h) and the system is not responsive. Everything reacts with a huge delay. Earlier this never happened( previous revisions), but I used only gcc4h versions. Haiku3D works good. I have Athlon 64 3500+.

Change History (21)

comment:1 Changed 7 years ago by diver

Might be a dupe of #8007.

comment:2 Changed 7 years ago by SeanCollins

I have tried to recreate this complaint with the exact same cpu " i know I have allot of computer shit laying around" and I was unable to.

I have a few recomendations for Premislaus

  1. clean your CPU cooler "overheating" 1a, check thermal compound on CPU and check Mother board cpu clocking profile.1b. does your cpu fan even work ?
  1. check your power supply "unstable clock speed due to voltage irregulatiry"
  1. run memtest "ram could be having issue's, will cuase haiku to behave badly but not always crash"
  1. try in safe mode. "potential driver issue"

try those and report back.

comment:3 in reply to:  2 Changed 7 years ago by Premislaus

Replying to SeanCollins:

I have tried to recreate this complaint with the exact same cpu " i know I have allot of computer shit laying around" and I was unable to.

I have a few recomendations for Premislaus

  1. clean your CPU cooler "overheating" 1a, check thermal compound on CPU and check Mother board cpu clocking profile.1b. does your cpu fan even work ?
  1. check your power supply "unstable clock speed due to voltage irregulatiry"
  1. run memtest "ram could be having issue's, will cuase haiku to behave badly but not always crash"
  1. try in safe mode. "potential driver issue"

try those and report back.

My computer works fine. I checked. My main system is Windows XP - there are not any problems.

After installing hrev44584 gcc4h, I do not have these problems with GLTeapot. Similar occurs only after starting the four GLTeapot( response of the system, drawing GUI). At one GLTeapot, some programs have slower start( StyleEdit, Debugger, mounting NTFS partition).

BTW On the gcc2h alpha, after turning off the Cool'n'Quiet in the BIOS, is a little better.

Last edited 7 years ago by Premislaus (previous) (diff)

comment:4 Changed 7 years ago by Hubert

Yes. I have the same in 44604 gcc2h on 1CPU. Helps change in ProcessController priority with normal to lower. But why normal priority in app takes priority in the operation of the system?

comment:5 Changed 7 years ago by Premislaus

Still occurs on hrevr1alpha4-44643. This is a PITA. I feel less responsive in gcc2h than gcc4h.

Last edited 7 years ago by Premislaus (previous) (diff)

comment:6 Changed 7 years ago by diver

comment:7 in reply to:  6 Changed 7 years ago by Premislaus

Replying to diver:

Could you try again with this image? http://deathstar.knuttinatoll.net/hammer/haiku_44701_gcc4_with_patch5.zip

How to burn this to a CD? ImgBurn do not support this (invalid format). Anyboot has the same extension and can be burned.

comment:8 Changed 7 years ago by diver

This is a raw image, it can be written directly to disk or USB stick.

comment:9 Changed 7 years ago by Premislaus

Blocked By: 8007 added

comment:10 Changed 7 years ago by Premislaus

Replying to diver:

This is a raw image, it can be written directly to disk or USB stick.

OK. I wrote directly to disk.

There is a big improvement, especially with the GUI drawing under heavy load. Launch programs, mounting partitions, compression, become longer. There is lag between click and reaction.

comment:11 Changed 7 years ago by Premislaus

My previous comment has introduced confusion. I'm sorry.

  1. In gcc2h when you run GLTeapot, the system responds with a huge delay. GUI draws slowly, you have to wait for the reactions of other programs.
  2. In gcc4h is a little better. Something similar I observed when 4 GLTeapot is running.

In idle and do not demanding things is normally.

There is something wrong with the allocation of CPU time in Haiku. The newly launched process, such as mount a partition, does not receive priority. You have to wait until the system responds to the launch of a program.

Along with this patch, GUI drawing is normal under heavy load (100% of CPU usage). You can start at the same time 6 GLTeapot, song and video (frame dropping). With this patch you have less waiting and I observe improve the system responsiveness. I have a much better feeling, impression.

Last edited 7 years ago by Premislaus (previous) (diff)

comment:12 Changed 7 years ago by Premislaus

Component: Applications/GLTeapotSystem/Kernel
Keywords: 100% CPU usage added
Summary: GLTeapot uses 100% cpu and the system is not responsive.Something is wrong with the allocation of CPU time.

comment:13 Changed 7 years ago by diver

Resolution: duplicate
Status: newclosed

Since jua's patch fixes this issue (confirmed by Premislaus on IRC), I'm going to close it as a dupe.

comment:14 Changed 7 years ago by diver

The only other concern I have related to this issue is that GLTeapot on a gcc2 nightly image makes GUI extremely slow, where as on a gcc4 nightly image only 4 GLTeapots produce similar result. Could this might be because of different versions of mesa lib?

comment:15 Changed 6 years ago by diver

Component: System/KernelDrivers/Graphics/radeon_hd
Keywords: GLTeapot one core not responsive 100% CPU usageGLTeapot one core not responsive 100% CPU usage
Platform: x86All

comment:16 Changed 6 years ago by Premislaus

On VESA is good with 1 and 6 GLTeapots. This is hrev 45427. I have radeon_hd driver.

Last edited 6 years ago by Premislaus (previous) (diff)

comment:17 Changed 6 years ago by diver

Blocked By: 8007 removed
Resolution: duplicate
Status: closedreopened

comment:18 Changed 5 years ago by Premislaus

I no longer have this computer

comment:19 Changed 5 years ago by kallisti5

Component: Drivers/Graphics/radeon_hdKits/OpenGL Kit/Software Rasterization

comment:20 Changed 5 years ago by kallisti5

Summary: Something is wrong with the allocation of CPU time.GLTeapot Performance Issues under swrast add-on

This isn't really related to radeon_hd. Moving to OpenGL kit.

comment:21 Changed 14 months ago by cocobean

Last edited 11 months ago by cocobean (previous) (diff)
Note: See TracTickets for help on using tickets.