Opened 7 years ago

Closed 4 months ago

#9066 closed bug (fixed)

Web+ crash when browsing address bar history.

Reported by: DaaT Owned by: leavengood
Priority: normal Milestone: R1
Component: Applications/WebPositive Version: R1/alpha3
Keywords: Cc:
Blocked By: Blocking:
Has a Patch: no Platform: All

Description (last modified by anevilyak)

I've been able to reproduce this. When I start typing an address, I use the up and down arrow keys to browse the list. Close that tab, the list remains in the other tab. Open a new tab, do it again, click the page, Web+ crashes. Also, small bug, when the list of recent sites first shows, even if you press the Up arrow, the first site of the list is selected, instead of the last. Here's the BT for the crash:

#0  0xffff0114 in ?? ()
#1  0x01f467f0 in debugger () from /boot/system/lib/gcc4/libroot.so
#2  0x01c3e048 in BPrivate::TextGapBuffer::FindChar ()
   from /boot/system/lib/gcc4/libbe.so
#3  0x01c19cab in BTextView::_TabExpandedStyledWidth ()
   from /boot/system/lib/gcc4/libbe.so
#4  0x01c1d21b in BTextView::PointAt () from /boot/system/lib/gcc4/libbe.so
#5  0x01c1e85d in BTextView::GetTextRegion ()
   from /boot/system/lib/gcc4/libbe.so
#6  0x01c1ee2b in BTextView::Highlight () from /boot/system/lib/gcc4/libbe.so
#7  0x01c1fb1a in BTextView::Select () from /boot/system/lib/gcc4/libbe.so
#8  0x0022bbd3 in TextViewCompleter::TextViewWrapper::SetEditViewState ()
#9  0x0022a2ff in BDefaultCompletionStyle::CancelChoice ()
#10 0x00229f8b in BAutoCompleter::CancelChoice ()
#11 0x0022b964 in TextViewCompleter::Filter ()
#12 0x01b836d3 in BLooper::_ApplyFilters () from /boot/system/lib/gcc4/libbe.so
#13 0x01b83745 in BLooper::_HandlerFilter ()
   from /boot/system/lib/gcc4/libbe.so
#14 0x01b837ff in BLooper::_TopLevelFilter ()
   from /boot/system/lib/gcc4/libbe.so
#15 0x01c36221 in BWindow::task_looper () from /boot/system/lib/gcc4/libbe.so
#16 0x01b83e66 in BLooper::_task0_ () from /boot/system/lib/gcc4/libbe.so
#17 0x01f4a247 in thread_entry () from /boot/system/lib/gcc4/libroot.so
#18 0x78137fec in ?? ()

Change History (7)

comment:1 Changed 7 years ago by anevilyak

Description: modified (diff)

comment:2 Changed 6 years ago by AGMS

May be related to bug #9217, if this bug is caused by bad selection ranges.

comment:3 Changed 5 years ago by pulkomandy

How do you close the tab so the list doesn't close with it? Or is that not possible anymore?

comment:4 Changed 5 years ago by DaaT

I can't make web+ crash this way anymore, but I can still close a tab while the list of recent sites is open and the list remains open in the tab now selected (after closing the previous one). I close the tab using alt+w.

comment:5 Changed 5 years ago by pulkomandy

Summary: Web+ crashWeb+ crash when browsing address bar history.

comment:6 Changed 5 years ago by DaaT

Just checked, the issue described in my comment (number 4) still happens in webkit 1.4.5.

comment:7 Changed 4 months ago by waddlesplash

Resolution: fixed
Status: newclosed

The list still being open appears to be a "feature", pressing up or down sets the address bar of the now-selected tab. The crash is fixed anyway, so closing this one.

Note: See TracTickets for help on using tickets.