Opened 8 years ago

Closed 7 years ago

Last modified 7 years ago

#9318 closed bug (fixed)

VirtualMemory: Invalid size

Reported by: dsjonny Owned by: axeld
Priority: normal Milestone: R1
Component: Preferences/VirtualMemory Version: R1/alpha4.1
Keywords: Cc:
Blocked By: Blocking:
Platform: All

Description

If there is no virtual memory enabled and no swap file present, I got invalid current swap size:

I have checked at Pootle, and do not found error in the translation.

I use R1A4.1 with Hungarian locale, but I got this earlier too. If I change the language to English or any other, there is no problem. I have no idea what may cause this.

Maybe there is a similar problem: #9238

Attachments (1)

vm_hu.png (16.0 KB ) - added by dsjonny 8 years ago.

Download all attachments as: .zip

Change History (8)

by dsjonny, 8 years ago

Attachment: vm_hu.png added

comment:1 by dsjonny, 8 years ago

I found only this in the syslog:

USER: app application/x-vnd.Haiku-VirtualMemory send to client failed: Bad port ID

And I found an old 200MB swap file in the /var, so it is independent of a swap file present or not.

comment:2 by kallisti5, 8 years ago

Are you using localized file names?

There should be checks around that usage bar to handle that logic.

comment:3 by anevilyak, 8 years ago

Probably a duplicate of #8541.

comment:4 by dsjonny, 8 years ago

I got the same result if I using localized filenames and if not.

comment:5 by dsjonny, 8 years ago

Still present in 45341 nightly.

comment:6 by diver, 7 years ago

Resolution: fixed
Status: newclosed

Should be fixed since hrev45732.

comment:7 by dsjonny, 7 years ago

Thank you!

Note: See TracTickets for help on using tickets.