#9423 closed bug (fixed)

Focus went back to last focused window while option "Focus follows mouse" is on.

Reported by: dknoto Owned by: stippi
Priority: normal Milestone: R1
Component: Servers/app_server Version: R1/Development
Keywords: Focus follows mouse Cc:
Blocked By: Blocking:
Has a Patch: no Platform: All

Description

Hi,
I found bug in focus behavior. Focus went back to last focused window while option "Focus follows mouse" is on, but it has to jump to window below mouse pointer. I'm going to illustrate this behavior on screen shots.

Attachments (3)

Focus-Bug-1.jpg (170.3 KB) - added by dknoto 15 months ago.
Create three windows. Move mouse pointer to left-down window.
Focus-Bug-2.jpg (170.2 KB) - added by dknoto 15 months ago.
Move mouse pointer to middle window in to area of upper window. Press ctrl+d.
Focus-Bug-3.jpg (166.9 KB) - added by dknoto 15 months ago.
Focus went back.

Download all attachments as: .zip

Change History (10)

Changed 15 months ago by dknoto

Create three windows. Move mouse pointer to left-down window.

Changed 15 months ago by dknoto

Move mouse pointer to middle window in to area of upper window. Press ctrl+d.

Changed 15 months ago by dknoto

Focus went back.

comment:1 Changed 14 months ago by axeld

  • Resolution set to invalid
  • Status changed from new to closed

That's done intentionally. Once you use the keyboard only, and don't move the mouse, focus follows mouse doesn't kick in. This improves the keyboard only use of FFM considerably.

comment:2 Changed 14 months ago by dknoto

I'm very frustrated. This explanation is idiotic.
If I use only keyboard this behavior generate many mistakes and redundant moves with mouse. It is VERY stupid, especially with jumps between workspaces.

comment:3 Changed 14 months ago by axeld

Well, I'm afraid you have to live with it.

And no, the explanation is not idiotic: you either use the mouse, or the keyboard, rarely both at the same time. And when you use the keyboard FFM is pretty much unusable, as you have no control over what's below the mouse cursor.

If you close a window using the mouse, the focus will go to the window below the mouse, if you close a window with the keyboard, the focus will go to the last focused window. I can't see how this is frustrating, it's just the perfect combination.

comment:4 Changed 13 months ago by dknoto

If you close a window using the mouse, the focus will go to the window below the mouse, if you close > a window with the keyboard, the focus will go to the last focused window. I can't see how this is
frustrating, it's just the perfect combination.

I finally have a moment of time to answer. I tested version hrev45404-gcc4-hybrid, Focus Follow Mouse mode, compared to version R4.1.

First example:

1) Run Terminal application, in my installation by double-click on desktop icon,

2) Move cursor to window centre, http://dl.dropbox.com/u/92245884/FFM-01.jpg

3) Run Pe application, http://dl.dropbox.com/u/92245884/FFM-02.jpg

4) Close Pe application by shortcut 'Left Alt + Q', http://dl.dropbox.com/u/92245884/FFM-03.jpg

Result: Desktop lost focus. In R4.1A it was working properly, focus landed in Terminal window.

Second example:

1) Go to workspace One in 3x3 desktop,

2) Go to workspace Two by shortcut "Left Ctrl + Left Alt + 'Right Arrow'",

3) Try to jump to workspace Three with the same shortcut.

Result: Desktop lost focus. You do not work any shortcut. In R4.1A it was working properly.

To put it mildly this is not a perfect combination :-(

comment:5 Changed 13 months ago by axeld

  • Component changed from User Interface to Servers/app_server
  • Resolution invalid deleted
  • Status changed from closed to reopened

That indeed sounds like bugs that should be fixed, thanks for the update. They don't match your original bug description at all, though, which is indeed how it should behave.

I recently fixed another bug in click-to-front mode, maybe this had unwanted side effects, I'll have a look in the not so distant future.

comment:6 Changed 11 months ago by diver

I wonder if hrev45665 changes anything?

comment:7 Changed 11 months ago by bonefish

  • Resolution set to fixed
  • Status changed from reopened to closed

As Axel wrote, the behavior as described in the ticket description is intentional. The bug described in comment:4, is a duplicate of #9595 and fixed in hrev45665.

Note: See TracTickets for help on using tickets.