Opened 6 years ago

Closed 5 years ago

#9676 closed bug (fixed)

[Deskbar] crashes in TExpandoMenuBar::MouseMoved

Reported by: diver Owned by: jscipione
Priority: normal Milestone: R1
Component: Applications/Deskbar Version: R1/Development
Keywords: Cc:
Blocked By: Blocking: #9998
Has a Patch: no Platform: All

Description

This is hrev45506.

I was trying to reproduce #8539 with the steps from its Description.

Attachments (1)

Deskbar-124-debug-15-04-2013-14-38-58.report (15.4 KB) - added by diver 6 years ago.

Download all attachments as: .zip

Change History (11)

comment:1 Changed 6 years ago by jscipione

Resolution: duplicate
Status: newclosed

Duplicate of #8539

comment:2 Changed 6 years ago by jscipione

Resolution: duplicate
Status: closedreopened

I suppose this isn't an exact duplicate of #8539 since that ticket describes a lockup and this one a crash although they are related. I found this bug to be quite difficult to reproduce but narrowed it down to either the B_ENTERED_VIEW or B_EXITED_VIEW case with message = NULL in the TExpandoMenuBar::MouseDown() method.

comment:3 Changed 6 years ago by awoesten

Got the same problem here today. What I did do, was running a fresh Haiku system ( hrev45717 ) having the Installer opened. I was installing to another disk and at the same time I changed resolution and background colors in the preflets. Then I moved the mouse over the deskbar and it accidently crashed. Following stuff was written into the syslog.

http://www.localmindprovider.com/haiku/bug-deskbar.png

Haiku running in a VirtualBox, 1 CPU, 512 MB RAM, hrev45717.

comment:4 Changed 6 years ago by jscipione

@awoesten:

Was your Deskbar in vertical or horizontal mode? If vertical mode, did you have the expander arrows turned on? If so, did you have any apps expanded at the time of the crash?

comment:5 Changed 6 years ago by awoesten

The deskbar was with default settings. So I guess vertical mode without expander and none of the apps were expanded.

comment:6 Changed 6 years ago by jscipione

Quite possibly is fixed in hrev45720, although it's hard to tell since triggering this bug is tough.

comment:7 Changed 6 years ago by diver

Same crash in hrev45754.

comment:8 Changed 6 years ago by diver

Blocking: 9998 added

comment:9 Changed 5 years ago by jscipione

Quite possibly fixed in hrev46195 as expander code was refactored. Please retest.

comment:10 Changed 5 years ago by jscipione

Resolution: fixed
Status: reopenedclosed

I'm assuming this one got fixed in hrev46195, please reopen if you experience this crash again.

Note: See TracTickets for help on using tickets.