Opened 6 years ago

Closed 9 months ago

#9677 closed bug (fixed)

Can't boot from HD / KDL On Boot with Anyboot

Reported by: scanty Owned by: bonefish
Priority: normal Milestone: R1
Component: System/Kernel Version: R1/Development
Keywords: boot-failure Cc:
Blocked By: #8345 Blocking:
Has a Patch: no Platform: All

Description

Hello All. This morning I tried to install Haiku to its own hard drive and had absolutely no success in doing so. I used an alpha 4.1 ISO to do this. GRUB found Haiku automagically, but couldn't boot it. I just get a black screen with a flashing cursor in the upper left corner.

I then tried anyboot from a USB stick (two different brands, Lexar and Kingston) and both caused a KDL on boot. I have attached a photo of the kernel output, but beware, it is not the best photo because I have hand-tremor from taking Lithium. It should however be clear enough to decipher what's going on. Hope we can resolve these bugs as I'd like to move away from VirtualBox and get onto real hardware.

Attachments (4)

KDL.JPG (228.8 KB ) - added by scanty 6 years ago.
KDL output from anyboot alpha 4.1
P4160221.JPG (242.3 KB ) - added by scanty 6 years ago.
KDL
P4160220.JPG (232.6 KB ) - added by scanty 6 years ago.
more KDL
P4160223.JPG (190.5 KB ) - added by scanty 6 years ago.
KDL bottom that got cut offf

Download all attachments as: .zip

Change History (20)

by scanty, 6 years ago

Attachment: KDL.JPG added

KDL output from anyboot alpha 4.1

comment:1 by scanty, 6 years ago

Note, with anyboot, I used 3 of the latest hrevs, as well as alpha 4.1

comment:2 by anevilyak, 6 years ago

What was the actual panic line above "Welcome to Kernel Debugging Land"?

comment:3 by scanty, 6 years ago

PANIC: looking up page failed for pa 0xef000

by scanty, 6 years ago

Attachment: P4160221.JPG added

KDL

by scanty, 6 years ago

Attachment: P4160220.JPG added

more KDL

by scanty, 6 years ago

Attachment: P4160223.JPG added

KDL bottom that got cut offf

comment:4 by scanty, 6 years ago

This new kernel panic is from the latest nightly, as of April 15, 2013

comment:5 by umccullough, 6 years ago

What was the top right of that screen out of curiosity? It should show the file where the assertion failure occurred.

comment:6 by anevilyak, 6 years ago

It would also help to know more about the hardware in this system.

comment:7 by scanty, 6 years ago

The system is a new HP Z220 workstation. There are 4x 3.2GHz Xeons, and 8GB of RAM. Display is nVidia Quadro K600. and sound is intel. It came with a 500GB drive, and I installed an extra 250GB drive just for haiku. That's pretty much it

comment:8 by anevilyak, 6 years ago

Component: - GeneralSystem/Kernel
Keywords: vm added
Owner: changed from nobody to bonefish
Status: newassigned
Version: R1/alpha4.1R1/Development

Looks like a VM problem of some kind in any case.

comment:9 by scanty, 6 years ago

Here is the panic assertion. Since it is very hard for me to take pictures, I transcribed it by hand. I hope there are no typos.

PANIC ASSERT FAILED (/Buildbot/nightly-uploader/workdir/haiku/src/system/kernel/arch/x86/paging/pae/X86VMTranslationMapPAE.cpp:231):*entry & 0x00000001LL) == 0; virtual adress:0x82000000, existing pte:0xf1692003

comment:10 by umccullough, 6 years ago

Cool, I'll add a quick link here to what appears to be the code in question for easy perusal:

http://cgit.haiku-os.org/haiku/tree/src/system/kernel/arch/x86/paging/pae/X86VMTranslationMapPAE.cpp#n229

comment:11 by anevilyak, 6 years ago

Blocked By: 8345 added

Thought this looked familiar...this is in fact a duplicate of #8345, though in the latter's case, none of the reporters are able to reliably replicate it like here, so that makes this case potentially a bit more interesting.

comment:12 by scanty, 6 years ago

Which part looks familiar, out of curiousity? There are really two bugs here and I should have filed separate reports.

  • Haiku (A4.1) won't boot off HD
  • Haiku KDLs with Anyboot, such like on a USB stick.

If you'd like I can separate the reports.

comment:13 by bonefish, 6 years ago

Looks very similar to #9520, which itself is marked a duplicate of #8345.

@scanty: Yes, please create a new ticket for the failure to boot off HD.

comment:14 by scanty, 6 years ago

This seems to be a 64-bit issue as well, as I tried and x86_64 anyboot image, and the same thing occurs. Seems like something is up with the bootloader but I don't have enough knowledge and experience to diagnose the problem.

comment:15 by waddlesplash, 15 months ago

Keywords: boot-failure added; vm removed

comment:16 by waddlesplash, 9 months ago

Resolution: fixed
Status: assignedclosed

#8345 was fixed and no-one else has seen this one reliably for a while; though before that was fixed, oco also had some hardware which reproduced it reliably. So probably the same story was true here.

Note: See TracTickets for help on using tickets.