Opened 6 years ago

Closed 6 years ago

Last modified 6 years ago

#10239 closed bug (fixed)

WebPositive crashes on BWebPage::requestDownload()

Reported by: Wizard Owned by: leavengood
Priority: normal Milestone: R1
Component: Applications/WebPositive Version: R1/Development
Keywords: crash download Cc:
Blocked By: Blocking: #10251, #10255, #10260
Has a Patch: no Platform: x86

Description

Cliking on any link pointig to binary file on any protocol causes WebPositive to crash.

Haiku hrev46415, gcc2hybrid, crosscompiled on linux-x64 host. Crash report attached.

Attachments (1)

WebPositive-6124-debug-24-11-2013-11-13-08.report (28.6 KB) - added by Wizard 6 years ago.
crash report

Download all attachments as: .zip

Change History (6)

Changed 6 years ago by Wizard

crash report

comment:1 Changed 6 years ago by pulkomandy

Resolution: fixed
Status: newclosed

Fixed in https://github.com/haiku/webkit/commit/587feb7f7bbebe901e7132fee7a6ec9e0635cfe2 and hrev46439. You'll have to wait for an update of the haikuwebkit package to see the results.

comment:2 Changed 6 years ago by anevilyak

Blocking: 10251 added

(In #10251) That's a dupe of #10239.

comment:3 Changed 6 years ago by anevilyak

Blocking: 10255 added

(In #10255) Yet another duplicate of #10239. As for how to know when it gets updated, when you see a commit indicating it was, i.e. http://cgit.haiku-os.org/haiku/commit/?id=cb7df3b1da881c3fadef628b0a0d5a122f131bd0

comment:4 Changed 6 years ago by anevilyak

Blocking: 10260 added

(In #10260) Duplicate of #10239

comment:5 Changed 6 years ago by bbjimmy

Maybe this should not be closed until the new haikuwebkit package is updated.

Note: See TracTickets for help on using tickets.